aboutsummaryrefslogtreecommitdiff
path: root/libs/libaio
diff options
context:
space:
mode:
authorRosen Penev <rosenp@gmail.com>2022-11-04 20:35:56 -0700
committerRosen Penev <rosenp@gmail.com>2022-11-05 10:32:10 -0700
commita75aaa452b0f814894ec0f0023436cac1dfe6fb3 (patch)
tree4d5de9d5392da13bebee283fcc8318e26747767a /libs/libaio
parent63b52599bf154c2f5918786a868f843c183bd4bf (diff)
libaio: update to 0.3.113
Signed-off-by: Rosen Penev <rosenp@gmail.com>
Diffstat (limited to 'libs/libaio')
-rw-r--r--libs/libaio/Makefile6
-rw-r--r--libs/libaio/patches/001_arches.patch4
-rw-r--r--libs/libaio/patches/002_arches_sh.patch8
-rw-r--r--libs/libaio/patches/003_arches_mips_fix_padding.patch10
4 files changed, 14 insertions, 14 deletions
diff --git a/libs/libaio/Makefile b/libs/libaio/Makefile
index 463b9657b..48501f705 100644
--- a/libs/libaio/Makefile
+++ b/libs/libaio/Makefile
@@ -8,12 +8,12 @@
include $(TOPDIR)/rules.mk
PKG_NAME:=libaio
-PKG_VERSION:=0.3.112
-PKG_RELEASE:=2
+PKG_VERSION:=0.3.113
+PKG_RELEASE:=$(AUTORELEASE)
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
PKG_SOURCE_URL:=https://releases.pagure.org/libaio
-PKG_HASH:=ab0462f2c9d546683e5147b1ce9c195fe95d07fac5bf362f6c01637955c3b492
+PKG_HASH:=2c44d1c5fd0d43752287c9ae1eb9c023f04ef848ea8d4aafa46e9aedb678200b
PKG_MAINTAINER:=
PKG_LICENSE:=LGPL-2.1-only
diff --git a/libs/libaio/patches/001_arches.patch b/libs/libaio/patches/001_arches.patch
index a0b801c4f..569c9a1da 100644
--- a/libs/libaio/patches/001_arches.patch
+++ b/libs/libaio/patches/001_arches.patch
@@ -34,7 +34,7 @@ Last-Update: 2014-10-09
+#include "syscall-parisc.h"
+#elif defined(__mips__)
+#include "syscall-mips.h"
- #elif defined(__aarch64__) || defined(__riscv)
+ #elif defined(__aarch64__) || defined(__loongarch__) || defined(__riscv)
#include "syscall-generic.h"
#else
--- /dev/null
@@ -96,7 +96,7 @@ Last-Update: 2014-10-09
+#endif /* _MIPS_SIM == _MIPS_SIM_NABI32 */
--- a/src/libaio.h
+++ b/src/libaio.h
-@@ -72,6 +72,7 @@ typedef enum io_iocb_cmd {
+@@ -74,6 +74,7 @@ typedef enum io_iocb_cmd {
/* big endian, 64 bits */
#elif defined(__powerpc64__) || defined(__s390x__) || \
diff --git a/libs/libaio/patches/002_arches_sh.patch b/libs/libaio/patches/002_arches_sh.patch
index b88863639..db6abea70 100644
--- a/libs/libaio/patches/002_arches_sh.patch
+++ b/libs/libaio/patches/002_arches_sh.patch
@@ -33,10 +33,10 @@ Description: Add SH supprt
- defined(__sh__) || defined(__bfin__) || defined(__MIPSEL__) || \
+ (defined(__sh__) && defined(__LITTLE_ENDIAN__)) || \
+ defined(__bfin__) || defined(__MIPSEL__) || \
- defined(__cris__) || (defined(__riscv) && __riscv_xlen == 32) || \
+ defined(__cris__) || defined(__loongarch32) || \
+ (defined(__riscv) && __riscv_xlen == 32) || \
(defined(__GNUC__) && defined(__BYTE_ORDER__) && \
- __BYTE_ORDER__ == __ORDER_LITTLE_ENDIAN__ && __SIZEOF_LONG__ == 4)
-@@ -84,6 +85,7 @@ typedef enum io_iocb_cmd {
+@@ -86,6 +87,7 @@ typedef enum io_iocb_cmd {
/* big endian, 32 bits */
#elif defined(__PPC__) || defined(__s390__) || \
(defined(__arm__) && defined(__ARMEB__)) || \
@@ -61,6 +61,6 @@ Description: Add SH supprt
#include "syscall-mips.h"
+#elif defined(__sh__)
+#include "syscall-sh.h"
- #elif defined(__aarch64__) || defined(__riscv)
+ #elif defined(__aarch64__) || defined(__loongarch__) || defined(__riscv)
#include "syscall-generic.h"
#else
diff --git a/libs/libaio/patches/003_arches_mips_fix_padding.patch b/libs/libaio/patches/003_arches_mips_fix_padding.patch
index 4e0a11878..539d236dc 100644
--- a/libs/libaio/patches/003_arches_mips_fix_padding.patch
+++ b/libs/libaio/patches/003_arches_mips_fix_padding.patch
@@ -17,18 +17,18 @@ Last-Update: 2014-07-23
- defined(__bfin__) || defined(__MIPSEL__) || \
+ defined(__bfin__) || \
+ (defined(__MIPSEL__) && !defined(__mips64)) || \
- defined(__cris__) || (defined(__riscv) && __riscv_xlen == 32) || \
+ defined(__cris__) || defined(__loongarch32) || \
+ (defined(__riscv) && __riscv_xlen == 32) || \
(defined(__GNUC__) && defined(__BYTE_ORDER__) && \
- __BYTE_ORDER__ == __ORDER_LITTLE_ENDIAN__ && __SIZEOF_LONG__ == 4)
-@@ -63,6 +64,7 @@ typedef enum io_iocb_cmd {
+@@ -64,6 +65,7 @@ typedef enum io_iocb_cmd {
/* little endian, 64 bits */
#elif defined(__ia64__) || defined(__x86_64__) || defined(__alpha__) || \
+ (defined(__mips64) && defined(__MIPSEL__)) || \
(defined(__aarch64__) && defined(__AARCH64EL__)) || \
+ defined(__loongarch64) || \
(defined(__riscv) && __riscv_xlen == 64) || \
- (defined(__GNUC__) && defined(__BYTE_ORDER__) && \
-@@ -75,6 +77,7 @@ typedef enum io_iocb_cmd {
+@@ -77,6 +79,7 @@ typedef enum io_iocb_cmd {
#elif defined(__powerpc64__) || defined(__s390x__) || \
(defined(__hppa__) && defined(__arch64__)) || \
(defined(__sparc__) && defined(__arch64__)) || \