aboutsummaryrefslogtreecommitdiff
path: root/libs/jose/Makefile
diff options
context:
space:
mode:
authorRosen Penev <rosenp@gmail.com>2022-09-17 15:22:53 -0700
committerRosen Penev <rosenp@gmail.com>2022-09-18 23:19:31 -0700
commitc61b70918b6c10f6fd726b098474736a7e0ae9cd (patch)
tree6e09131e81233fe352266cd3674508c04704f5be /libs/jose/Makefile
parentf8c25627ebe1d92fb89caa97f864e2972b79a63f (diff)
jose: fix static library usage
When libjose is built statically, it must use --whole-archive as it uses GCC's constructor attribute to initialize itself. Signed-off-by: Rosen Penev <rosenp@gmail.com>
Diffstat (limited to 'libs/jose/Makefile')
-rw-r--r--libs/jose/Makefile4
1 files changed, 1 insertions, 3 deletions
diff --git a/libs/jose/Makefile b/libs/jose/Makefile
index 6360a70d3..19b6c514d 100644
--- a/libs/jose/Makefile
+++ b/libs/jose/Makefile
@@ -19,15 +19,13 @@ PKG_MAINTAINER:=Tibor Dudlák <tibor.dudlak@gmail.com>
PKG_LICENSE:=Apache-2.0
PKG_LICENSE_FILES:=COPYING
-PKG_BUILD_DEPENDS:=openssl
-
include $(INCLUDE_DIR)/package.mk
include $(INCLUDE_DIR)/meson.mk
define Package/jose
SECTION:=utils
TITLE:=Provides a full crypto stack including key generation, signing and encryption.
- DEPENDS:=+jansson
+ DEPENDS:=+jansson +libopenssl +zlib
URL:=https://github.com/latchset/jose
endef