aboutsummaryrefslogtreecommitdiff
path: root/libs/icu
diff options
context:
space:
mode:
authorHirokazu MORIKAWA <morikw2@gmail.com>2020-12-24 15:18:56 +0900
committerHirokazu MORIKAWA <morikw2@gmail.com>2020-12-24 15:18:56 +0900
commitd6317132dd7040fcab492ba76ec60b6fa8ae4fe6 (patch)
tree1784033a8f77c52badc047e082a4be512bb1ca00 /libs/icu
parent740740d2195f1a483dbabcf2f82108f47256dccd (diff)
icu: update to 68.2
Maintainer: me Compile tested: head r15324-920b692, aarch64, x86_64 Run tested: (qemu-5.2.0) aarch64 Description: Update to 68.2 Signed-off-by: Hirokazu MORIKAWA <morikw2@gmail.com>
Diffstat (limited to 'libs/icu')
-rw-r--r--libs/icu/Makefile4
-rw-r--r--libs/icu/patches/000-dont-cpy-files-from-topdirs.patch2
-rw-r--r--libs/icu/patches/001-change_optimization_option.patch2
-rw-r--r--libs/icu/patches/002-Disable-LDFLAGSICUDT-for-Linux.patch5
-rw-r--r--libs/icu/patches/010-max_align_t.patch2
5 files changed, 4 insertions, 11 deletions
diff --git a/libs/icu/Makefile b/libs/icu/Makefile
index f2413b9a5..459e5a6be 100644
--- a/libs/icu/Makefile
+++ b/libs/icu/Makefile
@@ -9,13 +9,13 @@ include $(TOPDIR)/rules.mk
PKG_NAME:=icu4c
MAJOR_VERSION:=68
-MINOR_VERSION:=1
+MINOR_VERSION:=2
PKG_VERSION:=$(MAJOR_VERSION).$(MINOR_VERSION)
PKG_RELEASE:=1
PKG_SOURCE:=$(PKG_NAME)-$(MAJOR_VERSION)_$(MINOR_VERSION)-src.tgz
PKG_SOURCE_URL:=https://github.com/unicode-org/icu/releases/download/release-$(MAJOR_VERSION)-$(MINOR_VERSION)
-PKG_HASH:=a9f2e3d8b4434b8e53878b4308bd1e6ee51c9c7042e2b1a376abefb6fbb29f2d
+PKG_HASH:=c79193dee3907a2199b8296a93b52c5cb74332c26f3d167269487680d479d625
PKG_LICENSE:=ICU
PKG_LICENSE_FILES:=LICENSE
diff --git a/libs/icu/patches/000-dont-cpy-files-from-topdirs.patch b/libs/icu/patches/000-dont-cpy-files-from-topdirs.patch
index 55dc4859d..c77db6ee9 100644
--- a/libs/icu/patches/000-dont-cpy-files-from-topdirs.patch
+++ b/libs/icu/patches/000-dont-cpy-files-from-topdirs.patch
@@ -1,5 +1,3 @@
-diff --git a/Makefile.in b/Makefile.in
-index 9db6c52..6aa2273 100644
--- a/Makefile.in
+++ b/Makefile.in
@@ -190,7 +190,6 @@ install-icu: $(INSTALLED_BUILT_FILES)
diff --git a/libs/icu/patches/001-change_optimization_option.patch b/libs/icu/patches/001-change_optimization_option.patch
index 6914a0703..f4ee626d7 100644
--- a/libs/icu/patches/001-change_optimization_option.patch
+++ b/libs/icu/patches/001-change_optimization_option.patch
@@ -1,6 +1,6 @@
--- a/runConfigureICU
+++ b/runConfigureICU
-@@ -239,8 +239,8 @@
+@@ -239,8 +239,8 @@ case $platform in
THE_COMP="the GNU C++"
CC=gcc; export CC
CXX=g++; export CXX
diff --git a/libs/icu/patches/002-Disable-LDFLAGSICUDT-for-Linux.patch b/libs/icu/patches/002-Disable-LDFLAGSICUDT-for-Linux.patch
index bdab3f936..fd4767d28 100644
--- a/libs/icu/patches/002-Disable-LDFLAGSICUDT-for-Linux.patch
+++ b/libs/icu/patches/002-Disable-LDFLAGSICUDT-for-Linux.patch
@@ -10,8 +10,6 @@ Signed-off-by: Khem Raj <raj.khem@gmail.com>
source/config/mh-linux | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
-diff --git a/config/mh-linux b/config/mh-linux
-index 366f0cc..2689aab 100644
--- a/config/mh-linux
+++ b/config/mh-linux
@@ -23,7 +23,7 @@ LD_RPATH= -Wl,-zorigin,-rpath,'$$'ORIGIN
@@ -23,6 +21,3 @@ index 366f0cc..2689aab 100644
## Compiler switch to embed a library name
# The initial tab in the next line is to prevent icu-config from reading it.
---
-1.7.10.4
-
diff --git a/libs/icu/patches/010-max_align_t.patch b/libs/icu/patches/010-max_align_t.patch
index 0ad406b41..0a139b124 100644
--- a/libs/icu/patches/010-max_align_t.patch
+++ b/libs/icu/patches/010-max_align_t.patch
@@ -38,7 +38,7 @@
};
static const UText emptyText = UTEXT_INITIALIZER;
-@@ -584,7 +584,7 @@ utext_setup(UText *ut, int32_t extraSpace, UErrorCode *status) {
+@@ -584,7 +584,7 @@ utext_setup(UText *ut, int32_t extraSpac
// We need to heap-allocate storage for the new UText
int32_t spaceRequired = sizeof(UText);
if (extraSpace > 0) {