aboutsummaryrefslogtreecommitdiff
path: root/libs/icu
diff options
context:
space:
mode:
authorHirokazu MORIKAWA <morikw2@gmail.com>2016-12-26 12:04:27 +0900
committerHirokazu MORIKAWA <morikw2@gmail.com>2017-01-11 11:13:35 +0900
commit67b5e98f5be1cc8fbd92653b04210626db0d2e25 (patch)
tree6c9672cdce285906811fbe844c3d4f02e7d9a12f /libs/icu
parentc785ad365c46784f68c3ae4750f0a065369c9ad2 (diff)
icu: Bumped to v58.2
Maintainer: @nxhack Compile tested: ar71xx mips_24kc_musl-1.1.15 LEDE r2610-324bdf3 Run tested: NONE Description: icu: Bumped to v58.2 for emoji handling previous PR #2817 add patches/001-disable-strtod_l.patch missing xlocale.h in case of using musl. Signed-off-by: Hirokazu MORIKAWA <morikw2@gmail.com>
Diffstat (limited to 'libs/icu')
-rw-r--r--libs/icu/Makefile67
-rw-r--r--libs/icu/patches/000-dont-cpy-files-from-topdirs.patch2
-rw-r--r--libs/icu/patches/001-disable-strtod_l.patch26
3 files changed, 67 insertions, 28 deletions
diff --git a/libs/icu/Makefile b/libs/icu/Makefile
index c70ac166e..d820ff050 100644
--- a/libs/icu/Makefile
+++ b/libs/icu/Makefile
@@ -1,5 +1,5 @@
#
-# Copyright (C) 2006-2010 OpenWrt.org
+# Copyright (C) 2006-2016 OpenWrt.org
#
# This is free software, licensed under the GNU General Public License v2.
# See /LICENSE for more information.
@@ -8,17 +8,17 @@
include $(TOPDIR)/rules.mk
PKG_NAME:=icu4c
-PKG_VERSION:=55.1
+PKG_VERSION:=58.2
PKG_RELEASE:=1
-PKG_SOURCE:=$(PKG_NAME)-55_1-src.tgz
-PKG_SOURCE_URL:=http://download.icu-project.org/files/icu4c/55.1
-PKG_MD5SUM:=e2d523df79d6cb7855c2fbe284f4db29
+PKG_SOURCE:=$(PKG_NAME)-58_2-src.tgz
+PKG_SOURCE_URL:=http://download.icu-project.org/files/$(PKG_NAME)/$(PKG_VERSION)
+PKG_MD5SUM:=fac212b32b7ec7ab007a12dff1f3aea1
PKG_LICENSE:=ICU-1.8.1+
-PKG_LICENSE_FILES:=license.html
+PKG_LICENSE_FILES:=LICENSE
-PKG_MAINTAINER:=Mirko Vogt <mirko@openwrt.org>
+PKG_MAINTAINER:=Hirokazu MORIKAWA <morikw2@gmail.com>
PKG_INSTALL:=1
PKG_BUILD_PARALLEL:=1
@@ -26,7 +26,6 @@ PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
PKG_BUILD_DEPENDS:=icu/host
-
include $(INCLUDE_DIR)/package.mk
include $(INCLUDE_DIR)/host-build.mk
@@ -41,25 +40,39 @@ define Package/icu
DEPENDS:=+libstdcpp +libpthread
endef
-define Build/Configure
- $(call Build/Configure/Default, \
- --disable-debug \
- --enable-release \
- --enable-shared \
- --enable-static \
- --enable-draft \
- --enable-renaming \
- --disable-tracing \
- --disable-extras \
- --enable-dyload \
- --enable-layout \
- --enable-layoutex \
- --disable-tools \
- --disable-tests \
- --disable-samples \
- --with-cross-build="$(HOST_BUILD_DIR)" \
- )
-endef
+CONFIGURE_CMD:= ./runConfigureICU
+CONFIGURE_VARS:=
+CONFIGURE_ARGS:= \
+ Linux/gcc \
+ --disable-debug \
+ --enable-release \
+ --enable-shared \
+ --enable-static \
+ --enable-draft \
+ --enable-renaming \
+ --disable-tracing \
+ --disable-extras \
+ --enable-dyload \
+ --disable-tools \
+ --disable-tests \
+ --disable-samples \
+ --with-cross-build="$(HOST_BUILD_DIR)" \
+ --prefix=/usr
+
+HOST_CONFIGURE_CMD:= ./runConfigureICU
+HOST_CONFIGURE_VARS:=
+HOST_CONFIGURE_ARGS:= \
+ Linux/gcc \
+ --disable-debug \
+ --enable-release \
+ --enable-shared \
+ --enable-static \
+ --enable-draft \
+ --enable-renaming \
+ --disable-tracing \
+ --disable-extras \
+ --enable-dyload \
+ --prefix=$(HOST_BUILD_PREFIX)
define Build/InstallDev
$(INSTALL_DIR) \
diff --git a/libs/icu/patches/000-dont-cpy-files-from-topdirs.patch b/libs/icu/patches/000-dont-cpy-files-from-topdirs.patch
index cc7d93838..8b8cb7bc0 100644
--- a/libs/icu/patches/000-dont-cpy-files-from-topdirs.patch
+++ b/libs/icu/patches/000-dont-cpy-files-from-topdirs.patch
@@ -6,7 +6,7 @@ index 9db6c52..6aa2273 100644
$(INSTALL_SCRIPT) $(top_srcdir)/install-sh $(DESTDIR)$(pkgdatadir)/install-sh
@$(MKINSTALLDIRS) $(DESTDIR)$(libdir)/pkgconfig
$(INSTALL_DATA) $(ALL_PKGCONFIG_FILES) $(DESTDIR)$(libdir)/pkgconfig/
-- $(INSTALL_DATA) $(top_srcdir)/../license.html $(DESTDIR)$(pkgdatadir)/license.html
+- $(INSTALL_DATA) $(top_srcdir)/../LICENSE $(DESTDIR)$(pkgdatadir)/LICENSE
$(INSTALL_SCRIPT) $(top_builddir)/config/icu-config $(DESTDIR)$(bindir)/icu-config
$(INSTALL_DATA) $(top_builddir)/config/Makefile.inc $(DESTDIR)$(pkglibdir)/Makefile.inc
$(INSTALL_DATA) $(top_builddir)/config/pkgdata.inc $(DESTDIR)$(pkglibdir)/pkgdata.inc
diff --git a/libs/icu/patches/001-disable-strtod_l.patch b/libs/icu/patches/001-disable-strtod_l.patch
new file mode 100644
index 000000000..b84d14fc4
--- /dev/null
+++ b/libs/icu/patches/001-disable-strtod_l.patch
@@ -0,0 +1,26 @@
+--- a/configure.ac
++++ b/configure.ac
+@@ -893,8 +893,8 @@
+ AC_CHECK_FUNC(strtod_l)
+ if test x$ac_cv_func_strtod_l = xyes
+ then
+- CONFIG_CPPFLAGS="${CONFIG_CPPFLAGS} -DU_HAVE_STRTOD_L=1"
+- U_HAVE_STRTOD_L=1
++ CONFIG_CPPFLAGS="${CONFIG_CPPFLAGS} -DU_HAVE_STRTOD_L=0"
++ U_HAVE_STRTOD_L=0
+ else
+ CONFIG_CPPFLAGS="${CONFIG_CPPFLAGS} -DU_HAVE_STRTOD_L=0"
+ U_HAVE_STRTOD_L=0
+--- a/configure
++++ b/configure
+@@ -7053,8 +7053,8 @@
+
+ if test x$ac_cv_func_strtod_l = xyes
+ then
+- CONFIG_CPPFLAGS="${CONFIG_CPPFLAGS} -DU_HAVE_STRTOD_L=1"
+- U_HAVE_STRTOD_L=1
++ CONFIG_CPPFLAGS="${CONFIG_CPPFLAGS} -DU_HAVE_STRTOD_L=0"
++ U_HAVE_STRTOD_L=0
+ else
+ CONFIG_CPPFLAGS="${CONFIG_CPPFLAGS} -DU_HAVE_STRTOD_L=0"
+ U_HAVE_STRTOD_L=0