aboutsummaryrefslogtreecommitdiff
path: root/libs/ibrdtn
diff options
context:
space:
mode:
authorJohannes Morgenroth <morgenroth@ibr.cs.tu-bs.de>2014-08-20 12:38:55 +0200
committerJohannes Morgenroth <morgenroth@ibr.cs.tu-bs.de>2014-08-20 12:44:11 +0200
commitb51142a18b0075e954b759b312604d895e40fe54 (patch)
tree4ebe06c203c82afced4805ec1a4abf9c32b594ef /libs/ibrdtn
parent74e2ccff82af13ada57049674aa8f09e8d4e7379 (diff)
ibrdtn: add new package
The ibrdtn is a C++ library for DTN related objects to process bundle data and talk to the DTN daemon of IBR-DTN. It is development together with IBR-DTN an implementation of DTN stack following the Bundle Protocol RFC 5050. Signed-off-by: Johannes Morgenroth <morgenroth@ibr.cs.tu-bs.de>
Diffstat (limited to 'libs/ibrdtn')
-rw-r--r--libs/ibrdtn/Makefile50
1 files changed, 50 insertions, 0 deletions
diff --git a/libs/ibrdtn/Makefile b/libs/ibrdtn/Makefile
new file mode 100644
index 000000000..d86dcc336
--- /dev/null
+++ b/libs/ibrdtn/Makefile
@@ -0,0 +1,50 @@
+#
+# Copyright (C) 2014 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+include $(TOPDIR)/rules.mk
+
+PKG_NAME:=ibrdtn
+PKG_VERSION:=0.12.1
+PKG_RELEASE:=1
+
+PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
+PKG_SOURCE_URL:=http://www.ibr.cs.tu-bs.de/projects/ibr-dtn/releases
+PKG_MD5SUM:=96428dd4af541ea0c52db80776976a65
+PKG_MAINTAINER:=Johannes Morgenroth <morgenroth@ibr.cs.tu-bs.de>
+PKG_LICENSE:=Apache-2.0
+
+PKG_INSTALL:=1
+PKG_FIXUP:=libtool
+PKG_BUILD_DEPENDS:=ibrcommon zlib
+
+include $(INCLUDE_DIR)/package.mk
+
+define Package/ibrdtn
+ SECTION:=libs
+ CATEGORY:=Libraries
+ DEPENDS:=+ibrcommon +zlib
+ TITLE:=IBR-DTN Library
+endef
+
+define Package/ibrdtn/description
+ Base library for IBR-DTN daemon and tools.
+endef
+
+CONFIGURE_ARGS += \
+ --with-compression
+
+define Build/InstallDev
+ $(INSTALL_DIR) $(1)
+ $(CP) $(PKG_INSTALL_DIR)/* $(1)/
+endef
+
+define Package/ibrdtn/install
+ $(INSTALL_DIR) $(1)/usr/lib
+ $(CP) $(PKG_INSTALL_DIR)/usr/lib/lib$(PKG_NAME){.so,-$(PKG_VERSION_MAJOR).$(PKG_VERSION_MINOR).so.*} $(1)/usr/lib/
+endef
+
+$(eval $(call BuildPackage,ibrdtn))