aboutsummaryrefslogtreecommitdiff
path: root/libs/ibrcommon/Makefile
diff options
context:
space:
mode:
authorRosen Penev <rosenp@gmail.com>2018-12-24 13:45:19 -0800
committerRosen Penev <rosenp@gmail.com>2018-12-24 13:46:42 -0800
commita8c7dd57a35b850ebdec7a8d59489bc25fdecbca (patch)
tree02c78f89a30609e36ecc8840d7ca589603507762 /libs/ibrcommon/Makefile
parent724ddd2f94599e96e92fc6c8eb86abf32ac212f6 (diff)
ibrcommon: Allow usage of uclibc++
Allows having only one libc++ installed. Signed-off-by: Rosen Penev <rosenp@gmail.com>
Diffstat (limited to 'libs/ibrcommon/Makefile')
-rw-r--r--libs/ibrcommon/Makefile5
1 files changed, 3 insertions, 2 deletions
diff --git a/libs/ibrcommon/Makefile b/libs/ibrcommon/Makefile
index 4d677dc74..e4806441f 100644
--- a/libs/ibrcommon/Makefile
+++ b/libs/ibrcommon/Makefile
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
PKG_NAME:=ibrcommon
PKG_VERSION:=1.0.1
-PKG_RELEASE:=4
+PKG_RELEASE:=5
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
PKG_SOURCE_URL:=http://www.ibr.cs.tu-bs.de/projects/ibr-dtn/releases
@@ -20,12 +20,13 @@ PKG_LICENSE:=Apache-2.0
PKG_INSTALL:=1
PKG_FIXUP:=libtool
+include $(INCLUDE_DIR)/uclibc++.mk
include $(INCLUDE_DIR)/package.mk
define Package/ibrcommon
SECTION:=libs
CATEGORY:=Libraries
- DEPENDS:=+libstdcpp +libpthread +librt +libnl +libopenssl
+ DEPENDS:=$(CXX_DEPENDS) +libpthread +librt +libnl +libopenssl
TITLE:=IBR Common C++ Library
endef