aboutsummaryrefslogtreecommitdiff
path: root/libs/ibrcommon/Makefile
diff options
context:
space:
mode:
authorJohannes Morgenroth <morgenroth@ibr.cs.tu-bs.de>2014-08-20 12:37:09 +0200
committerJohannes Morgenroth <morgenroth@ibr.cs.tu-bs.de>2014-08-20 12:43:58 +0200
commit74e2ccff82af13ada57049674aa8f09e8d4e7379 (patch)
treea25cd8ad3b1511b384b3b6c274bc9804706b57da /libs/ibrcommon/Makefile
parentc8b84ec8aefb26c14c92488d9b548a077f60e374 (diff)
ibrcommon: add new package
The ibrcommon is a C++ abstraction library for several platforms (linux, win32, osx, ...) and is development together with IBR-DTN an implementation of DTN stack following the Bundle Protocol RFC 5050. Signed-off-by: Johannes Morgenroth <morgenroth@ibr.cs.tu-bs.de>
Diffstat (limited to 'libs/ibrcommon/Makefile')
-rw-r--r--libs/ibrcommon/Makefile50
1 files changed, 50 insertions, 0 deletions
diff --git a/libs/ibrcommon/Makefile b/libs/ibrcommon/Makefile
new file mode 100644
index 000000000..fb95b950c
--- /dev/null
+++ b/libs/ibrcommon/Makefile
@@ -0,0 +1,50 @@
+#
+# Copyright (C) 2014 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+include $(TOPDIR)/rules.mk
+
+PKG_NAME:=ibrcommon
+PKG_VERSION:=0.12.1
+PKG_RELEASE:=1
+
+PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
+PKG_SOURCE_URL:=http://www.ibr.cs.tu-bs.de/projects/ibr-dtn/releases
+PKG_MD5SUM:=45681f48138bbbbd17384d25dc91454a
+PKG_MAINTAINER:=Johannes Morgenroth <morgenroth@ibr.cs.tu-bs.de>
+PKG_LICENSE:=Apache-2.0
+
+PKG_INSTALL:=1
+PKG_FIXUP:=libtool
+PKG_BUILD_DEPENDS:=libnl libopenssl
+
+include $(INCLUDE_DIR)/package.mk
+
+define Package/ibrcommon
+ SECTION:=libs
+ CATEGORY:=Libraries
+ DEPENDS:=+libstdcpp +libpthread +librt +libnl +libopenssl
+ TITLE:=IBR Common C++ Library
+endef
+
+CONFIGURE_ARGS += \
+ --with-openssl
+
+define Package/ibrcommon/description
+ A library with common functions for C++.
+endef
+
+define Build/InstallDev
+ $(INSTALL_DIR) $(1)
+ $(CP) $(PKG_INSTALL_DIR)/* $(1)/
+endef
+
+define Package/ibrcommon/install
+ $(INSTALL_DIR) $(1)/usr/lib
+ $(CP) $(PKG_INSTALL_DIR)/usr/lib/lib$(PKG_NAME){.so,-$(PKG_VERSION_MAJOR).$(PKG_VERSION_MINOR).so.*} $(1)/usr/lib/
+endef
+
+$(eval $(call BuildPackage,ibrcommon))