aboutsummaryrefslogtreecommitdiff
path: root/libs/hyperscan/Makefile
diff options
context:
space:
mode:
authorJohn Audia <therealgraysky@proton.me>2024-02-22 15:21:46 -0500
committerRosen Penev <rosenp@gmail.com>2024-02-22 16:04:08 -0800
commitbb574d7b69a0178c7d5dca52cc5b84214eebe806 (patch)
tree457a0aecbdb274b6533a8f7eb361e320934de17f /libs/hyperscan/Makefile
parent46ed5094692d4da54cdea3db6b7fa78d8044781a (diff)
hyperscan: symlinks redundant ABI shared objects
Use $(CP) macro rather than $(INSTALL_DATA) to preserve symlinks on shared objects which saves approx 11.8 M of space. From hyperscan-runtime_5.4.2-1: % ls -lh /usr/lib/libhs* -rw-r--r-- 1 root root 4.7M Feb 16 14:29 /usr/lib/libhs.so -rw-r--r-- 1 root root 4.7M Feb 16 14:29 /usr/lib/libhs.so.5 -rw-r--r-- 1 root root 4.7M Feb 16 14:29 /usr/lib/libhs.so.5.4.2 -rw-r--r-- 1 root root 1.2M Feb 16 14:29 /usr/lib/libhs_runtime.so -rw-r--r-- 1 root root 1.2M Feb 16 14:29 /usr/lib/libhs_runtime.so.5 -rw-r--r-- 1 root root 1.2M Feb 16 14:29 /usr/lib/libhs_runtime.so.5.4.2 % grep Installed-Size /usr/lib/opkg/info/hyperscan-runtime.control Installed-Size: 18370560 From hyperscan-runetime_5.4.2-2 (created by this PR): % ls -lh /usr/lib/libhs* lrwxr-xr-x 1 root root 10 Feb 22 15:56 /usr/lib/libhs.so -> libhs.so.5 lrwxr-xr-x 1 root root 14 Feb 22 15:56 /usr/lib/libhs.so.5 -> libhs.so.5.4.2 -rwxr-xr-x 1 root root 4.6M Feb 22 15:27 /usr/lib/libhs.so.5.4.2 lrwxr-xr-x 1 root root 18 Feb 22 15:56 /usr/lib/libhs_runtime.so -> libhs_runtime.so.5 lrwxr-xr-x 1 root root 22 Feb 22 15:56 /usr/lib/libhs_runtime.so.5 -> libhs_runtime.so.5.4.2 -rwxr-xr-x 1 root root 1.2M Feb 22 15:27 /usr/lib/libhs_runtime.so.5.4.2 % grep Installed-Size /usr/lib/opkg/info/hyperscan-runtime.control Installed-Size: 5918720 Credit to @efahl for pointing this out. Build system: x86/64 Build-tested: x86/64/AMD Cezanne Run-tested: x86/64/AMD Cezanne Signed-off-by: John Audia <therealgraysky@proton.me>
Diffstat (limited to 'libs/hyperscan/Makefile')
-rw-r--r--libs/hyperscan/Makefile6
1 files changed, 3 insertions, 3 deletions
diff --git a/libs/hyperscan/Makefile b/libs/hyperscan/Makefile
index ce106afa8..92f97f3b9 100644
--- a/libs/hyperscan/Makefile
+++ b/libs/hyperscan/Makefile
@@ -7,7 +7,7 @@ include $(TOPDIR)/rules.mk
PKG_NAME:=hyperscan
PKG_VERSION:=5.4.2
-PKG_RELEASE:=1
+PKG_RELEASE:=2
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
PKG_SOURCE_URL:=https://codeload.github.com/intel/hyperscan/tar.gz/v$(PKG_VERSION)?
@@ -62,7 +62,7 @@ define Build/InstallDev
$(INSTALL_DIR) $(1)/usr/include/hs
$(INSTALL_DATA) $(PKG_INSTALL_DIR)/usr/include/hs/* $(1)/usr/include/hs/
$(INSTALL_DIR) $(1)/usr/lib
- $(INSTALL_DATA) $(PKG_INSTALL_DIR)/usr/lib/libhs* $(1)/usr/lib/
+ $(CP) $(PKG_INSTALL_DIR)/usr/lib/libhs* $(1)/usr/lib/
$(INSTALL_DIR) $(1)/usr/lib/pkgconfig
$(INSTALL_DATA) $(PKG_BUILD_DIR)/libhs.pc $(1)/usr/lib/pkgconfig/libhs.pc
endef
@@ -75,7 +75,7 @@ endef
define Package/hyperscan-runtime/install
$(INSTALL_DIR) $(1)/usr/lib
- $(INSTALL_DATA) $(PKG_INSTALL_DIR)/usr/lib/libhs* $(1)/usr/lib/
+ $(CP) $(PKG_INSTALL_DIR)/usr/lib/libhs* $(1)/usr/lib/
endef
$(eval $(call BuildPackage,hyperscan-headers))