aboutsummaryrefslogtreecommitdiff
path: root/libs/hwloc
diff options
context:
space:
mode:
authorRosen Penev <rosenp@gmail.com>2018-11-13 11:55:22 -0800
committerRosen Penev <rosenp@gmail.com>2018-11-13 12:12:32 -0800
commitac346e48d77df63407246b6994720b12cfcdb119 (patch)
tree9b767406be542417b32d118655cd6850d4b7c993 /libs/hwloc
parentd8bb8c3ff6da1d9aa8484d2f17b098e1b06fd3b6 (diff)
libhwloc: Update to 2.0.2
Fix buildbot by disabling several libraries that get automatically picked up. Signed-off-by: Rosen Penev <rosenp@gmail.com>
Diffstat (limited to 'libs/hwloc')
-rw-r--r--libs/hwloc/Makefile12
1 files changed, 8 insertions, 4 deletions
diff --git a/libs/hwloc/Makefile b/libs/hwloc/Makefile
index bf2dbfa64..a19903271 100644
--- a/libs/hwloc/Makefile
+++ b/libs/hwloc/Makefile
@@ -6,12 +6,12 @@
include $(TOPDIR)/rules.mk
PKG_NAME:=hwloc
-PKG_VERSION:=2.0.1
+PKG_VERSION:=2.0.2
PKG_RELEASE:=1
-PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
-PKG_SOURCE_URL:=https://download.open-mpi.org/release/$(PKG_NAME)/v2.0/
-PKG_HASH:=f1156df22fc2365a31a3dc5f752c53aad49e34a5e22d75ed231cd97eaa437f9d
+PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
+PKG_SOURCE_URL:=https://download.open-mpi.org/release/$(PKG_NAME)/v2.0
+PKG_HASH:=14457d70e6f98ee9eb3f2940000da4bac99909a49560ef2fdf4eacd286410cde
PKG_LICENSE:=BSD-3-Clause
PKG_MAINTAINER:=W. Michael Petullo <mike@flyn.org>
@@ -63,6 +63,10 @@ $(call Package/hwloc/Default/description)
This package contains the hwloc libraries.
endef
+CONFIGURE_ARGS += \
+ --disable-libxml2 \
+ --disable-libudev
+
define Build/InstallDev
$(INSTALL_DIR) $(STAGING_DIR)/usr/include
$(CP) $(PKG_INSTALL_DIR)/usr/include/hwloc.h $(STAGING_DIR)/usr/include/