aboutsummaryrefslogtreecommitdiff
path: root/libs/h2o
diff options
context:
space:
mode:
authorPeter van Dijk <peter.van.dijk@powerdns.com>2021-04-25 15:00:39 +0200
committerRosen Penev <rosenp@gmail.com>2021-04-25 12:26:42 -0700
commit6ffe955dccc1016031c3e2f60a5a37556645451a (patch)
tree4b35552f74a45b1d346d05f694ba9e21d8d91a59 /libs/h2o
parent00268c9bc621976f4c37384569c2dfa578e552a8 (diff)
h2o: remove useless ruby dependency
h2o is the library dnsdist uses to offer DNS over HTTPS to clients. dnsdist is the only user of h2o in this tree. While h2o can depend on Ruby (to build mruby support), this is disabled in the OpenWRT build of h2o. Hence, the Ruby dependency is unnecessary, and removing it saves a few megabytes of disk space. Signed-off-by: Peter van Dijk <peter.van.dijk@powerdns.com>
Diffstat (limited to 'libs/h2o')
-rw-r--r--libs/h2o/Makefile8
1 files changed, 4 insertions, 4 deletions
diff --git a/libs/h2o/Makefile b/libs/h2o/Makefile
index 0f15aeee6..18aef9b01 100644
--- a/libs/h2o/Makefile
+++ b/libs/h2o/Makefile
@@ -2,7 +2,7 @@ include $(TOPDIR)/rules.mk
PKG_NAME:=h2o
PKG_VERSION:=2.2.6
-PKG_RELEASE:=7
+PKG_RELEASE:=8
PKG_SOURCE_URL:=https://codeload.github.com/h2o/h2o/tar.gz/v${PKG_VERSION}?
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
@@ -15,7 +15,7 @@ PKG_LICENSE_FILES:=LICENSE
include $(INCLUDE_DIR)/package.mk
include ../../devel/ninja/ninja-cmake.mk
-PKG_BUILD_DEPENDS:=ruby/host libwslay
+PKG_BUILD_DEPENDS:=libwslay
CMAKE_OPTIONS += \
-DBUILD_SHARED_LIBS=ON \
@@ -26,7 +26,7 @@ define Package/libh2o-evloop
CATEGORY:=Libraries
TITLE:=H2O Library compiled with its own event loop
URL:=https://h2o.examp1e.net/
- DEPENDS:=+libopenssl +zlib +libyaml +ruby
+ DEPENDS:=+libopenssl +zlib +libyaml
endef
define Package/libh2o
@@ -34,7 +34,7 @@ define Package/libh2o
CATEGORY:=Libraries
TITLE:=H2O Library compiled with libuv
URL:=https://h2o.examp1e.net/
- DEPENDS:=+libuv +libopenssl +zlib +libyaml +ruby
+ DEPENDS:=+libuv +libopenssl +zlib +libyaml
endef
define Build/InstallDev