aboutsummaryrefslogtreecommitdiff
path: root/libs/gpgme
diff options
context:
space:
mode:
authorDaniel Golle <daniel@makrotopia.org>2022-03-24 22:30:03 +0000
committerDaniel Golle <daniel@makrotopia.org>2022-03-24 22:32:05 +0000
commitd7799595bd74992145172706b5e65f71658e0e63 (patch)
tree82ac6b74267ebc9e08ab97bd03cdfb7f93c3826c /libs/gpgme
parentbed70d5f4b366f0fe90d4b0cda5a78f91aa4a738 (diff)
gpgme: update to version 1.17.1
Remove backported patch which is now included in the upstream release. Signed-off-by: Daniel Golle <daniel@makrotopia.org>
Diffstat (limited to 'libs/gpgme')
-rw-r--r--libs/gpgme/Makefile6
-rw-r--r--libs/gpgme/patches/001-Support-closefrom-also-for-glibc.patch27
2 files changed, 3 insertions, 30 deletions
diff --git a/libs/gpgme/Makefile b/libs/gpgme/Makefile
index da2612680..ed3ec8cc9 100644
--- a/libs/gpgme/Makefile
+++ b/libs/gpgme/Makefile
@@ -1,12 +1,12 @@
include $(TOPDIR)/rules.mk
PKG_NAME:=gpgme
-PKG_VERSION:=1.16.0
-PKG_RELEASE:=2
+PKG_VERSION:=1.17.1
+PKG_RELEASE:=1
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
PKG_SOURCE_URL:=https://gnupg.org/ftp/gcrypt/$(PKG_NAME)
-PKG_HASH:=6c8cc4aedb10d5d4c905894ba1d850544619ee765606ac43df7405865de29ed0
+PKG_HASH:=711eabf5dd661b9b04be9edc9ace2a7bc031f6bd9d37a768d02d0efdef108f5f
PKG_MAINTAINER:=Daniel Golle <daniel@makrotopia.org>
PKG_LICENSE:=GPL-3.0-or-later
diff --git a/libs/gpgme/patches/001-Support-closefrom-also-for-glibc.patch b/libs/gpgme/patches/001-Support-closefrom-also-for-glibc.patch
deleted file mode 100644
index b4164ae20..000000000
--- a/libs/gpgme/patches/001-Support-closefrom-also-for-glibc.patch
+++ /dev/null
@@ -1,27 +0,0 @@
-From: Jiri Kucera <sanczes@gmail.com>
-Date: Sun, 25 Jul 2021 09:35:54 +0000 (+0200)
-Subject: core: Support closefrom also for glibc.
-X-Git-Url: http://git.gnupg.org/cgi-bin/gitweb.cgi?p=gpgme.git;a=commitdiff_plain;h=4b64774b6d13ffa4f59dddf947a97d61bcfa2f2e
-
-core: Support closefrom also for glibc.
-
-* src/posix-io.c (_gpgme_io_spawn): Use glibc's closefrom.
---
-
-Since 2.34, glibc introduces closefrom (the implementation
-follows *BSD standard).
-
-Signed-off-by: Werner Koch <wk@gnupg.org>
----
-
---- a/src/posix-io.c
-+++ b/src/posix-io.c
-@@ -570,7 +570,7 @@ _gpgme_io_spawn (const char *path, char
- if (fd_list[i].fd > fd)
- fd = fd_list[i].fd;
- fd++;
--#if defined(__sun) || defined(__FreeBSD__)
-+#if defined(__sun) || defined(__FreeBSD__) || defined(__GLIBC__)
- closefrom (fd);
- max_fds = fd;
- #else /*!__sun */