aboutsummaryrefslogtreecommitdiff
path: root/libs/gpgme
diff options
context:
space:
mode:
authorTianling Shen <cnsztl@immortalwrt.org>2023-05-17 20:15:52 +0800
committerRosen Penev <rosenp@gmail.com>2023-05-18 10:29:29 +0300
commit1dcaf5210e110567ba17fa2085d022663898b839 (patch)
tree44ae172af0a51dd0456b7a781b16f090520a4200 /libs/gpgme
parent8591e8fb3f0400b25793543600ba4e9a6f93abe0 (diff)
gpgme: fix compilation with musl 1.2.4
musl 1.2.4 deprecated legacy "LFS64" ("large file support") interfaces so just having _GNU_SOURCE defined is not enough anymore. Manually pass -D_LARGEFILE64_SOURCE to allow to keep using LFS64 definitions. Signed-off-by: Tianling Shen <cnsztl@immortalwrt.org>
Diffstat (limited to 'libs/gpgme')
-rw-r--r--libs/gpgme/Makefile6
1 files changed, 5 insertions, 1 deletions
diff --git a/libs/gpgme/Makefile b/libs/gpgme/Makefile
index fca33261a..de1436d19 100644
--- a/libs/gpgme/Makefile
+++ b/libs/gpgme/Makefile
@@ -2,7 +2,7 @@ include $(TOPDIR)/rules.mk
PKG_NAME:=gpgme
PKG_VERSION:=1.18.0
-PKG_RELEASE:=1
+PKG_RELEASE:=2
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
PKG_SOURCE_URL:=https://gnupg.org/ftp/gcrypt/$(PKG_NAME)
@@ -52,6 +52,10 @@ CONFIGURE_ARGS += \
--disable-g13-test \
--enable-languages="cpp"
+ifneq ($(CONFIG_USE_MUSL),)
+ TARGET_CFLAGS += -D_LARGEFILE64_SOURCE
+endif
+
define Build/InstallDev
$(INSTALL_DIR) $(1)/usr/include/gpgme++
$(INSTALL_DATA) \