aboutsummaryrefslogtreecommitdiff
path: root/libs/gpgme/Makefile
diff options
context:
space:
mode:
authorMatt Merhar <mattmerhar@protonmail.com>2020-12-13 21:24:54 -0500
committerMatt Merhar <mattmerhar@protonmail.com>2020-12-13 22:20:33 -0500
commit91a6168ded3351312094615a742cda1673f062fe (patch)
tree6b338e7c11363e7790132a801375383477884fb6 /libs/gpgme/Makefile
parent49d6b72150cc7aea4ec2fcf46c6f8e7815cf2f16 (diff)
gpgme: install gpgme-config to host bin
This is necessary for at least fwknop to properly detect the library. The change was modeled after how gpg-error-config is installed in the libgpg-error package. Signed-off-by: Matt Merhar <mattmerhar@protonmail.com>
Diffstat (limited to 'libs/gpgme/Makefile')
-rw-r--r--libs/gpgme/Makefile11
1 files changed, 10 insertions, 1 deletions
diff --git a/libs/gpgme/Makefile b/libs/gpgme/Makefile
index 1123f579a..da766a341 100644
--- a/libs/gpgme/Makefile
+++ b/libs/gpgme/Makefile
@@ -2,7 +2,7 @@ include $(TOPDIR)/rules.mk
PKG_NAME:=gpgme
PKG_VERSION:=1.15.0
-PKG_RELEASE:=1
+PKG_RELEASE:=2
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
PKG_SOURCE_URL:=https://gnupg.org/ftp/gcrypt/$(PKG_NAME)
@@ -83,6 +83,15 @@ define Build/InstallDev
$(INSTALL_DATA) \
$(PKG_INSTALL_DIR)/usr/lib/cmake/Gpgmepp/*.cmake \
$(1)/usr/lib/cmake/Gpgmepp
+
+ $(INSTALL_DIR) $(2)/bin $(1)/usr/bin
+ $(INSTALL_BIN) \
+ $(PKG_INSTALL_DIR)/usr/bin/gpgme-config \
+ $(2)/bin/
+ $(SED) \
+ 's,^\(prefix\|exec_prefix\)=.*,\1=$(STAGING_DIR)/usr,g' \
+ $(2)/bin/gpgme-config
+ $(LN) -sf $(STAGING_DIR)/host/bin/gpgme-config $(1)/usr/bin/gpgme-config
endef
define Package/libgpgme/install