aboutsummaryrefslogtreecommitdiff
path: root/libs/gperf/patches
diff options
context:
space:
mode:
authorejurgensen <espenjurgensen@gmail.com>2017-07-24 23:23:00 +0200
committerejurgensen <espenjurgensen@gmail.com>2017-07-24 23:23:00 +0200
commitb5af9e0ab2259fc83cc6615158b6a14eda3a524f (patch)
tree83f13921d42a3b6118db2cad9a2330e434f36f75 /libs/gperf/patches
parent08ad088ed7e0ae68d1db0369d51d55f457d7fa5b (diff)
gperf: Update to 3.1
The patch fixes a problem where an incorrect getline.h would get included (not gperf's own which resides in ./lib) Signed-off-by: Espen Jürgensen <espenjurgensen+openwrt@gmail.com>
Diffstat (limited to 'libs/gperf/patches')
-rw-r--r--libs/gperf/patches/100-include_own_first.patch26
1 files changed, 26 insertions, 0 deletions
diff --git a/libs/gperf/patches/100-include_own_first.patch b/libs/gperf/patches/100-include_own_first.patch
new file mode 100644
index 000000000..6936f35db
--- /dev/null
+++ b/libs/gperf/patches/100-include_own_first.patch
@@ -0,0 +1,26 @@
+diff --git a/lib/Makefile.in b/lib/Makefile.in
+index 29bbf92..cf2bf3c 100644
+--- a/lib/Makefile.in
++++ b/lib/Makefile.in
+@@ -61,7 +61,7 @@ SHELL = /bin/sh
+ VPATH = $(srcdir)
+
+ OBJECTS = getopt.$(OBJEXT) getopt1.$(OBJEXT) getline.$(OBJEXT) hash.$(OBJEXT)
+-CPPFLAGS = @CPPFLAGS@ -I$(srcdir)
++CPPFLAGS = -I$(srcdir) @CPPFLAGS@
+
+ TARGETLIB = libgp.a
+
+diff --git a/src/Makefile.in b/src/Makefile.in
+index 6866ffd..bd4df14 100644
+--- a/src/Makefile.in
++++ b/src/Makefile.in
+@@ -64,7 +64,7 @@ VPATH = $(srcdir)
+ OBJECTS = version.$(OBJEXT) positions.$(OBJEXT) options.$(OBJEXT) keyword.$(OBJEXT) keyword-list.$(OBJEXT) \
+ input.$(OBJEXT) bool-array.$(OBJEXT) hash-table.$(OBJEXT) search.$(OBJEXT) output.$(OBJEXT) main.$(OBJEXT)
+ LIBS = ../lib/libgp.a @GPERF_LIBM@
+-CPPFLAGS = @CPPFLAGS@ -I. -I$(srcdir)/../lib
++CPPFLAGS = -I. -I$(srcdir)/../lib @CPPFLAGS@
+
+ TARGETPROG = gperf$(EXEEXT)
+