aboutsummaryrefslogtreecommitdiff
path: root/libs/gnutls
diff options
context:
space:
mode:
authorSebastian Kemper <sebastian_ml@gmx.net>2023-05-13 20:54:01 +0200
committerSebastian Kemper <sebastian_ml@gmx.net>2023-05-13 20:59:08 +0200
commit7310e7fc99d9750408a49b2ace522c31902e15ca (patch)
treef22f7f9389edd3669a9d7719f78fa1400a54ac07 /libs/gnutls
parent391f0979475f0c7485f7ea3d09ca62c6f7287145 (diff)
gnutls: load libunistring-optional gnulib module
Since a few days staging_dir/host/share/aclocal/ contains new m4 files (libunistring-base.m4, libunistring-optional.m4, libunistring.m4 etc.) that get applied during autoreconf. This changes the libunistring setup enough that we run into problem (builds fail). Load the libunistring-optional gnulib module in configure.ac to be able to add/use the new configure switch "--with-included-libunistring". This is at most a workaround. This should be followed up with gnutls upstream to clean this up. Signed-off-by: Sebastian Kemper <sebastian_ml@gmx.net>
Diffstat (limited to 'libs/gnutls')
-rw-r--r--libs/gnutls/Makefile3
-rw-r--r--libs/gnutls/patches/030-unistring-optional.patch11
2 files changed, 13 insertions, 1 deletions
diff --git a/libs/gnutls/Makefile b/libs/gnutls/Makefile
index dc94591c2..ec7f72d64 100644
--- a/libs/gnutls/Makefile
+++ b/libs/gnutls/Makefile
@@ -7,7 +7,7 @@ include $(TOPDIR)/rules.mk
PKG_NAME:=gnutls
PKG_VERSION:=3.8.0
-PKG_RELEASE:=1
+PKG_RELEASE:=2
PKG_BUILD_FLAGS:=no-mips16
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.xz
@@ -132,6 +132,7 @@ CONFIGURE_ARGS+= \
--without-idn \
--with-default-trust-store-dir=/etc/ssl/certs/ \
--with-included-unistring \
+ --with-included-libunistring \
--with-librt-prefix="$(LIBRT_ROOT_DIR)/" \
--with-pic \
--with-system-priority-file="" \
diff --git a/libs/gnutls/patches/030-unistring-optional.patch b/libs/gnutls/patches/030-unistring-optional.patch
new file mode 100644
index 000000000..6b42caee8
--- /dev/null
+++ b/libs/gnutls/patches/030-unistring-optional.patch
@@ -0,0 +1,11 @@
+--- a/configure.ac
++++ b/configure.ac
+@@ -471,6 +471,8 @@ DEFAULT_VALGRINDFLAGS='-q --error-exitco
+
+ gl_VALGRIND_TESTS_DEFAULT_NO
+
++gl_LIBUNISTRING_OPTIONAL
++
+ dnl Note that g*l_INIT are run after we check for library capabilities,
+ dnl to prevent issues from caching lib dependencies. See discussion
+ dnl in https://bugs.gentoo.org/show_bug.cgi?id=494940 and