aboutsummaryrefslogtreecommitdiff
path: root/libs/gnutls
diff options
context:
space:
mode:
authorNikos Mavrogiannopoulos <nmav@gnutls.org>2015-05-04 18:41:07 +0200
committerNikos Mavrogiannopoulos <nmav@gnutls.org>2015-05-04 18:41:07 +0200
commit606d375b6fc5911dc7b45719cbacd683002a1054 (patch)
tree6bf8fb4788b021cf6b1fde323454bbca1b9ce118 /libs/gnutls
parentc2f5b6fac4e95303bfa1a0a4d8b033e7abbce484 (diff)
gnutls: updated to 3.4.1
Signed-off-by: Nikos Mavrogiannopoulos <nmav@gnutls.org>
Diffstat (limited to 'libs/gnutls')
-rw-r--r--libs/gnutls/Makefile8
-rw-r--r--libs/gnutls/patches/001-libopts-detection.patch84
2 files changed, 4 insertions, 88 deletions
diff --git a/libs/gnutls/Makefile b/libs/gnutls/Makefile
index ea8aa53d0..40b807802 100644
--- a/libs/gnutls/Makefile
+++ b/libs/gnutls/Makefile
@@ -8,14 +8,14 @@
include $(TOPDIR)/rules.mk
PKG_NAME:=gnutls
-PKG_VERSION:=3.4.0
-PKG_RELEASE:=2
+PKG_VERSION:=3.4.1
+PKG_RELEASE:=1
PKG_USE_MIPS16:=0
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.xz
PKG_SOURCE_URL:=ftp://ftp.gnutls.org/gcrypt/gnutls/v3.4
-PKG_MD5SUM:=aa015c2666b031044edfb01b01980d84
-PKG_FIXUP:=autoreconf gettext-version
+PKG_MD5SUM:=2d04f34fa25b45f9dcb9104c0394e12e
+#PKG_FIXUP:=autoreconf gettext-version
PKG_MAINTAINER:=Nikos Mavrogiannopoulos <nmav@gnutls.org>
PKG_LICENSE:=LGPLv2.1+
diff --git a/libs/gnutls/patches/001-libopts-detection.patch b/libs/gnutls/patches/001-libopts-detection.patch
deleted file mode 100644
index eb69f0052..000000000
--- a/libs/gnutls/patches/001-libopts-detection.patch
+++ /dev/null
@@ -1,84 +0,0 @@
-diff --git a/configure.ac b/configure.ac
-index 7c454cd..185ebb6 100644
---- a/configure.ac
-+++ b/configure.ac
-@@ -64,7 +64,7 @@ if test "$enable_tools" != "no" || test "$enable_doc" != "no"; then
- ***
- *** autogen not found. Will not link against libopts.
- *** ]])
-- enable_local_libopts=yes
-+ included_libopts=yes
- fi
- fi
-
-@@ -523,7 +523,7 @@ fi
-
- AM_CONDITIONAL(ENABLE_TROUSERS, test "$with_tpm" != "no")
-
--enable_local_libopts=no
-+included_libopts=no
- if test "$enable_tools" != "no" || test "$enable_doc" != "no"; then
- LIBOPTS_CHECK([src/libopts])
- if test "$NEED_LIBOPTS_DIR" = "true";then
-@@ -540,15 +540,17 @@ if test "$enable_tools" != "no" || test "$enable_doc" != "no"; then
- if test -z "$missing_baks"; then
- AC_SUBST([AUTOGEN], [/bin/true])
- fi
-- enable_local_libopts=yes
-+ included_libopts=yes
- fi
- else
- # Need to ensure the relevant conditionals get set
- gl_STDNORETURN_H
- AM_CONDITIONAL([INSTALL_LIBOPTS],[false])
- AM_CONDITIONAL([NEED_LIBOPTS], [false])
-+ included_libopts=yes
- fi
--AM_CONDITIONAL(NEED_LIBOPTS, test "$enable_local_libopts" = "yes")
-+
-+AM_CONDITIONAL(NEED_LIBOPTS, test "$included_libopts" = "yes")
-
- AC_CHECK_TYPE(ssize_t,
- [
-@@ -896,7 +898,7 @@ AC_MSG_NOTICE([summary of build options:
- Compiler: ${CC}
- CFlags: ${CFLAGS}
- Library types: Shared=${enable_shared}, Static=${enable_static}
-- Local libopts: ${enable_local_libopts}
-+ Local libopts: ${included_libopts}
- Local libtasn1: ${included_libtasn1}
- Use nettle-mini: ${mini_nettle}
- ])
-diff --git a/src/Makefile.am b/src/Makefile.am
-index 4105ab6..b907249 100644
---- a/src/Makefile.am
-+++ b/src/Makefile.am
-@@ -30,13 +30,6 @@ if ENABLE_CRYWRAP
- SUBDIRS += crywrap
- endif
-
--if NEED_LIBOPTS
--LIBOPTS = libopts/libopts.la
--SUBDIRS += libopts
--else
--LIBOPTS = $(LIBOPTS_LDADD)
--endif
--
- EXTRA_DIST = args-std.def
-
- AM_CFLAGS = $(WARN_CFLAGS) $(WERROR_CFLAGS)
-@@ -49,6 +42,14 @@ AM_CPPFLAGS = \
- -I$(srcdir)/../extra/includes \
- $(LIBOPTS_CFLAGS)
-
-+if NEED_LIBOPTS
-+LIBOPTS = libopts/libopts.la
-+SUBDIRS += libopts
-+AM_CPPFLAGS += -I$(srcdir)/libopts
-+else
-+LIBOPTS = $(LIBOPTS_LDADD)
-+endif
-+
- bin_PROGRAMS = psktool gnutls-cli-debug certtool
- if ENABLE_SRP
- bin_PROGRAMS += srptool