aboutsummaryrefslogtreecommitdiff
path: root/libs/gnutls
diff options
context:
space:
mode:
authorNikos Mavrogiannopoulos <nmav@gnutls.org>2015-01-17 09:41:37 +0100
committerNikos Mavrogiannopoulos <nmav@gnutls.org>2015-01-17 09:42:20 +0100
commit2a4dd62715ce7c3d1a4f7a5a65dcae8b0c0c948f (patch)
treec5bea6d3fbfdfd508ebdb0d99c7051522642168c /libs/gnutls
parent66d6ba168d139ba605a20e72a3263f9e6b7621bd (diff)
gnutls: updated to 3.3.12
Signed-off-by: Nikos Mavrogiannopoulos <nmav@gnutls.org>
Diffstat (limited to 'libs/gnutls')
-rw-r--r--libs/gnutls/Makefile6
-rw-r--r--libs/gnutls/patches/002-ocsp-in-tools.patch51
2 files changed, 3 insertions, 54 deletions
diff --git a/libs/gnutls/Makefile b/libs/gnutls/Makefile
index eb6ce944a..a7aedf9df 100644
--- a/libs/gnutls/Makefile
+++ b/libs/gnutls/Makefile
@@ -8,13 +8,13 @@
include $(TOPDIR)/rules.mk
PKG_NAME:=gnutls
-PKG_VERSION:=3.3.11
-PKG_RELEASE:=2
+PKG_VERSION:=3.3.12
+PKG_RELEASE:=1
PKG_USE_MIPS16:=0
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.xz
PKG_SOURCE_URL:=ftp://ftp.gnutls.org/gcrypt/gnutls/v3.3
-PKG_MD5SUM:=b657e3010c10cae2244e7ce79ee3d446
+PKG_MD5SUM:=a37b20b4352a5f542367ded904729c90
PKG_MAINTAINER:=Nikos Mavrogiannopoulos <nmav@gnutls.org>
PKG_INSTALL:=1
diff --git a/libs/gnutls/patches/002-ocsp-in-tools.patch b/libs/gnutls/patches/002-ocsp-in-tools.patch
deleted file mode 100644
index 94008e4e2..000000000
--- a/libs/gnutls/patches/002-ocsp-in-tools.patch
+++ /dev/null
@@ -1,51 +0,0 @@
-diff --git a/src/cli-debug.c b/src/cli-debug.c
-index 5f9eb00..a8dde6c 100644
---- a/src/cli-debug.c
-+++ b/src/cli-debug.c
-@@ -165,8 +165,10 @@ static const TLS_TEST tls_tests[] = {
- #endif
- {"for max record size (RFC6066) support", test_max_record_size, "yes",
- "no", "dunno"},
-+#ifdef ENABLE_OCSP
- {"for OCSP status response (RFC6066) support", test_ocsp_status, "yes",
- "no", "dunno"},
-+#endif
- {"for OpenPGP authentication (RFC6091) support", test_openpgp1,
- "yes", "no", "dunno"},
- {NULL, NULL, NULL, NULL, NULL}
-diff --git a/src/common.c b/src/common.c
-index fff9449..ffa1896 100644
---- a/src/common.c
-+++ b/src/common.c
-@@ -572,9 +572,11 @@ int print_info(gnutls_session_t session, int verbose, int print_cert)
- printf("- Options:");
- if (gnutls_safe_renegotiation_status(session)!=0)
- printf(" safe renegotiation,");
-+#ifdef ENABLE_OCSP
- if (gnutls_ocsp_status_request_get(session, &resp)==0) {
- printf(" OCSP status request%s,", gnutls_ocsp_status_request_is_checked(session,0)!=0?"":"[ignored]");
- }
-+#endif
- printf("\n");
-
- #ifdef ENABLE_DTLS_SRTP
-diff --git a/src/tests.c b/src/tests.c
-index 6cb251d..5c45159 100644
---- a/src/tests.c
-+++ b/src/tests.c
-@@ -246,6 +246,7 @@ test_code_t test_safe_renegotiation(gnutls_session_t session)
- return ret;
- }
-
-+#ifdef ENABLE_OCSP
- test_code_t test_ocsp_status(gnutls_session_t session)
- {
- int ret;
-@@ -275,6 +276,7 @@ test_code_t test_ocsp_status(gnutls_session_t session)
-
- return TEST_FAILED;
- }
-+#endif
-
- test_code_t test_safe_renegotiation_scsv(gnutls_session_t session)
- {