aboutsummaryrefslogtreecommitdiff
path: root/libs/gnutls/Makefile
diff options
context:
space:
mode:
authorDaniel Golle <daniel@makrotopia.org>2020-12-26 17:56:54 +0000
committerDaniel Golle <dangowrt@users.noreply.github.com>2021-01-03 00:18:29 +0000
commitec7109ec124ebacb7f225642a4d42a3d48a7d658 (patch)
treec3baea678fe38d9c4b0a94d4e1db109f1e74ef54 /libs/gnutls/Makefile
parenta64b08a2256e1580253eed5d474016461b6e5fcd (diff)
gnutls: package libdane
Signed-off-by: Daniel Golle <daniel@makrotopia.org>
Diffstat (limited to 'libs/gnutls/Makefile')
-rw-r--r--libs/gnutls/Makefile27
1 files changed, 21 insertions, 6 deletions
diff --git a/libs/gnutls/Makefile b/libs/gnutls/Makefile
index 4da737433..d21bde599 100644
--- a/libs/gnutls/Makefile
+++ b/libs/gnutls/Makefile
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
PKG_NAME:=gnutls
PKG_VERSION:=3.7.0
-PKG_RELEASE:=1
+PKG_RELEASE:=2
PKG_USE_MIPS16:=0
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.xz
@@ -37,6 +37,7 @@ PKG_CONFIG_DEPENDS:= \
CONFIG_GNUTLS_SRP \
CONFIG_GNUTLS_TPM \
CONFIG_LIBNETTLE_MINI \
+ CONFIG_PACKAGE_libgnutls-dane \
include $(INCLUDE_DIR)/package.mk
@@ -80,7 +81,7 @@ $(call Package/gnutls/Default)
CATEGORY:=Utilities
SUBMENU:=Encryption
TITLE+= (utilities)
- DEPENDS+= +libgnutls
+ DEPENDS+= +libgnutls +PACKAGE_libgnutls-dane:libgnutls-dane
endef
define Package/gnutls-utils/description
@@ -99,6 +100,12 @@ $(call Package/gnutls/Default)
DEPENDS+= +libnettle +!LIBNETTLE_MINI:libgmp +GNUTLS_EXT_LIBTASN1:libtasn1 +GNUTLS_PKCS11:p11-kit +GNUTLS_CRYPTODEV:kmod-cryptodev +libatomic
endef
+define Package/libgnutls-dane
+$(call Package/gnutls/Default)
+ TITLE+= (libgnutls-dane library)
+ DEPENDS:= +libgnutls +libunbound
+endef
+
define Package/libgnutls/description
$(call Package/gnutls/Default/description)
This package contains the GnuTLS shared library, needed by other programs.
@@ -118,8 +125,6 @@ CONFIGURE_ARGS+= \
--disable-seccomp-tests \
--disable-tests \
--disable-valgrind-tests \
- \
- --disable-libdane \
--disable-ssl2-support \
--disable-ssl3-support \
--enable-local-libopts \
@@ -178,16 +183,20 @@ ifeq ($(CONFIG_GNUTLS_CRYPTODEV),y)
CONFIGURE_ARGS += --enable-cryptodev
endif
+ifeq ($(CONFIG_PACKAGE_libgnutls-dane),)
+CONFIGURE_ARGS += --disable-libdane
+endif
+
define Build/InstallDev
$(INSTALL_DIR) $(1)/usr/include $(1)/usr/lib/pkgconfig
$(CP) \
- $(PKG_INSTALL_DIR)/usr/lib/libgnutls.so* \
+ $(PKG_INSTALL_DIR)/usr/lib/*.so* \
$(1)/usr/lib/
$(CP) \
$(PKG_INSTALL_DIR)/usr/include/gnutls \
$(1)/usr/include/
$(CP) \
- $(PKG_INSTALL_DIR)/usr/lib/pkgconfig/gnutls.pc \
+ $(PKG_INSTALL_DIR)/usr/lib/pkgconfig/*.pc \
$(1)/usr/lib/pkgconfig/
endef
@@ -244,7 +253,13 @@ define Package/libgnutls/install
$(CP) $(PKG_INSTALL_DIR)/usr/lib/libgnutls.so.* $(1)/usr/lib/
endef
+define Package/libgnutls-dane/install
+ $(INSTALL_DIR) $(1)/usr/lib
+ $(CP) $(PKG_INSTALL_DIR)/usr/lib/libgnutls-dane.so.* $(1)/usr/lib/
+endef
+
$(eval $(call BuildPackage,certtool))
$(eval $(call BuildPackage,gnutls-utils))
$(eval $(call BuildPackage,libgnutls))
+$(eval $(call BuildPackage,libgnutls-dane))