aboutsummaryrefslogtreecommitdiff
path: root/libs/gnutls/Makefile
diff options
context:
space:
mode:
authorJohn Audia <graysky@archlinux.us>2022-03-20 11:55:22 -0400
committerJohn Audia <graysky@archlinux.us>2022-03-30 06:18:45 -0400
commite305f1bcb9ea2be387b6ea096e006399d7f22f5a (patch)
treecc5bba4ade4586900b353690b4c7d7c097993bb2 /libs/gnutls/Makefile
parent7fe4a663d3530cad6eaca8f639972111c6fc6b4f (diff)
gnutls: Update to 3.7.4
Bump to latest upstream release. Rebased existing patches. This version introduces certificate compression support, and with that, optional dependencies on zlib and zstd. When configure picks them up, build will fail due to missing dependencies: Package libgnutls is missing dependencies for the following libraries: libz.so.1 libzstd.so.1 Disable zlib and zstd support to avoid that. Signed-off-by: John Audia <graysky@archlinux.us> [disable zlib and zstd] Signed-off-by: Stijn Tintel <stijn@linux-ipv6.be>
Diffstat (limited to 'libs/gnutls/Makefile')
-rw-r--r--libs/gnutls/Makefile8
1 files changed, 5 insertions, 3 deletions
diff --git a/libs/gnutls/Makefile b/libs/gnutls/Makefile
index 90ca24c72..1fe5915b0 100644
--- a/libs/gnutls/Makefile
+++ b/libs/gnutls/Makefile
@@ -8,13 +8,13 @@
include $(TOPDIR)/rules.mk
PKG_NAME:=gnutls
-PKG_VERSION:=3.7.2
+PKG_VERSION:=3.7.4
PKG_RELEASE:=$(AUTORELEASE)
PKG_USE_MIPS16:=0
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.xz
PKG_SOURCE_URL:=https://www.gnupg.org/ftp/gcrypt/gnutls/v3.7
-PKG_HASH:=646e6c5a9a185faa4cea796d378a1ba8e1148dbb197ca6605f95986a25af2752
+PKG_HASH:=e6adbebcfbc95867de01060d93c789938cf89cc1d1f6ef9ef661890f6217451f
PKG_FIXUP:=autoreconf gettext-version
PKG_MAINTAINER:=Nikos Mavrogiannopoulos <nmav@gnutls.org>
PKG_LICENSE:=LGPL-2.1-or-later
@@ -134,7 +134,9 @@ CONFIGURE_ARGS+= \
--with-included-unistring \
--with-librt-prefix="$(LIBRT_ROOT_DIR)/" \
--with-pic \
- --with-system-priority-file=""
+ --with-system-priority-file="" \
+ --without-libzstd \
+ --without-zlib
ifneq ($(CONFIG_GNUTLS_EXT_LIBTASN1),y)
CONFIGURE_ARGS += --with-included-libtasn1