aboutsummaryrefslogtreecommitdiff
path: root/libs/gnutls/Makefile
diff options
context:
space:
mode:
authorNikos Mavrogiannopoulos <n.mavrogiannopoulos@gmail.com>2019-08-02 21:15:00 +0200
committerNikos Mavrogiannopoulos <n.mavrogiannopoulos@gmail.com>2019-08-02 21:27:39 +0200
commit15884f28a1ea30f8b0dc0b6fa5b295653460f871 (patch)
treeb866c77028015e6ac29ac51f2e216e9e1b704f95 /libs/gnutls/Makefile
parent932c76fa740acb0d68a46b78e2bc0eafd5fe13d6 (diff)
gnutls: updated to 3.6.9
Signed-off-by: Nikos Mavrogiannopoulos <n.mavrogiannopoulos@gmail.com>
Diffstat (limited to 'libs/gnutls/Makefile')
-rw-r--r--libs/gnutls/Makefile14
1 files changed, 9 insertions, 5 deletions
diff --git a/libs/gnutls/Makefile b/libs/gnutls/Makefile
index 36837c111..61312207e 100644
--- a/libs/gnutls/Makefile
+++ b/libs/gnutls/Makefile
@@ -8,13 +8,13 @@
include $(TOPDIR)/rules.mk
PKG_NAME:=gnutls
-PKG_VERSION:=3.6.8
-PKG_RELEASE:=2
+PKG_VERSION:=3.6.9
+PKG_RELEASE:=1
PKG_USE_MIPS16:=0
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.xz
PKG_SOURCE_URL:=https://www.gnupg.org/ftp/gcrypt/gnutls/v3.6
-PKG_HASH:=aa81944e5635de981171772857e72be231a7e0f559ae0292d2737de475383e83
+PKG_HASH:=4331fca55817ecdd74450b908a6c29b4f05bb24dd13144c6284aa34d872e1fcb
#PKG_FIXUP:=autoreconf gettext-version
PKG_MAINTAINER:=Nikos Mavrogiannopoulos <nmav@gnutls.org>
PKG_LICENSE:=LGPLv2.1+
@@ -104,7 +104,10 @@ $(call Package/gnutls/Default/description)
This package contains the GnuTLS shared library, needed by other programs.
endef
-
+# We disable the configuration file (system-priority-file) because
+# the use of configuration increases the non-shared memory used by
+# the library and we don't provide an openwrt-specific configuration
+# anyway.
CONFIGURE_ARGS+= \
--enable-shared \
--enable-static \
@@ -124,7 +127,8 @@ CONFIGURE_ARGS+= \
--with-default-trust-store-dir=/etc/ssl/certs/ \
--with-included-unistring \
--with-librt-prefix="$(LIBRT_ROOT_DIR)/" \
- --with-pic
+ --with-pic \
+ --with-system-priority-file=""
ifneq ($(CONFIG_GNUTLS_EXT_LIBTASN1),y)
CONFIGURE_ARGS += --with-included-libtasn1