aboutsummaryrefslogtreecommitdiff
path: root/libs/glib2
diff options
context:
space:
mode:
authorRosen Penev <rosenp@gmail.com>2020-09-28 22:37:48 -0700
committerRosen Penev <rosenp@gmail.com>2020-09-30 18:33:32 -0700
commitf132daf59eeb39a26ade3de1bae29a2328fd0d67 (patch)
treeb3f1819b9127c54825900d1456222f0f20f70e89 /libs/glib2
parentecbe2cc625e27fb94e7b0b611c7e683b346c1018 (diff)
glib2: remove static library hack
There's a better and faster way to do this. Signed-off-by: Rosen Penev <rosenp@gmail.com>
Diffstat (limited to 'libs/glib2')
-rw-r--r--libs/glib2/Makefile17
1 files changed, 1 insertions, 16 deletions
diff --git a/libs/glib2/Makefile b/libs/glib2/Makefile
index 1fa58fa39..2331cbe85 100644
--- a/libs/glib2/Makefile
+++ b/libs/glib2/Makefile
@@ -49,6 +49,7 @@ TARGET_CFLAGS += -ffunction-sections -fdata-sections
TARGET_LDFLAGS += -Wl,--gc-sections -liconv $(if $(INTL_FULL),-lintl)
COMP_ARGS= \
+ -Ddefault_library=both \
-Diconv=external \
-Dselinux=disabled \
-Dlibmount=disabled \
@@ -69,22 +70,6 @@ COMP_ARGS= \
MESON_HOST_ARGS += $(COMP_ARGS) -Dxattr=false
MESON_ARGS += $(COMP_ARGS) -Dxattr=true -Db_lto=true
-# hack to compile static libraries
-define Build/Compile
- $(call Build/Compile/Meson)
- $(call Ninja,-C $(MESON_BUILD_DIR) install,DESTDIR="$(PKG_INSTALL_DIR)")
- $(call Meson, \
- --reconfigure \
- --buildtype plain \
- --native-file $(PKG_BUILD_DIR)/openwrt-native.txt \
- --cross-file $(PKG_BUILD_DIR)/openwrt-cross.txt \
- -Ddefault_library=static \
- $(MESON_ARGS) \
- $(MESON_BUILD_DIR) \
- $(PKG_BUILD_DIR), \
- $(MESON_VARS))
-endef
-
define Build/InstallDev
$(INSTALL_DIR) $(1)/usr/bin
$(CP) \