aboutsummaryrefslogtreecommitdiff
path: root/libs/glib2
diff options
context:
space:
mode:
authorEtienne CHAMPETIER <champetier.etienne@gmail.com>2014-07-16 21:07:34 +0200
committerEtienne CHAMPETIER <champetier.etienne@gmail.com>2014-07-23 01:35:34 +0200
commit26e00eef1e8b52535a2af5bb2ae268ce7cc1d26f (patch)
tree4bbe8b8714e3a01862bb0cbde07b7be94130c025 /libs/glib2
parenta801f8edcd3f51a79b8c4b485780b1911bf2642c (diff)
glib2: fix compilation in my fedora20 mock
see #72 Signed-off-by: Etienne CHAMPETIER <champetier.etienne@gmail.com>
Diffstat (limited to 'libs/glib2')
-rw-r--r--libs/glib2/Makefile37
1 files changed, 19 insertions, 18 deletions
diff --git a/libs/glib2/Makefile b/libs/glib2/Makefile
index c9dd7b692..bdb353069 100644
--- a/libs/glib2/Makefile
+++ b/libs/glib2/Makefile
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
PKG_NAME:=glib2
PKG_VERSION:=2.41.1
-PKG_RELEASE:=1
+PKG_RELEASE:=2
PKG_SOURCE:=glib-$(PKG_VERSION).tar.xz
PKG_BUILD_DIR:=$(BUILD_DIR)/glib-$(PKG_VERSION)
@@ -40,23 +40,24 @@ define Package/glib2/description
The GLib library of C routines
endef
-define Build/Configure
- $(call Build/Configure/Default, \
- --enable-shared \
- --enable-static \
- --enable-debug=no \
- --disable-selinux \
- --disable-fam \
- $(if $(ICONV_FULL),--with-libiconv=gnu) \
- , \
- glib_cv_stack_grows=no \
- glib_cv_uscore=no \
- ac_cv_path_GLIB_GENMARSHAL=$(STAGING_DIR_HOST)/bin/glib-genmarshal \
- ac_cv_func_mmap_fixed_mapped=yes \
- ac_cv_func_posix_getpwuid_r=yes \
- ac_cv_func_posix_getgrgid_r=yes \
- );
-endef
+HOST_CONFIGURE_ARGS += \
+ --disable-selinux
+
+CONFIGURE_ARGS += \
+ --enable-shared \
+ --enable-static \
+ --enable-debug=no \
+ --disable-selinux \
+ --disable-fam \
+ $(if $(ICONV_FULL),--with-libiconv=gnu)
+
+CONFIGURE_VARS += \
+ glib_cv_stack_grows=no \
+ glib_cv_uscore=no \
+ ac_cv_path_GLIB_GENMARSHAL=$(STAGING_DIR_HOST)/bin/glib-genmarshal \
+ ac_cv_func_mmap_fixed_mapped=yes \
+ ac_cv_func_posix_getpwuid_r=yes \
+ ac_cv_func_posix_getgrgid_r=yes
define Build/InstallDev
$(INSTALL_DIR) $(1)/usr/include