aboutsummaryrefslogtreecommitdiff
path: root/libs/glib2/Makefile
diff options
context:
space:
mode:
authorAndre Heider <a.heider@gmail.com>2023-03-23 09:09:13 +0100
committerAndre Heider <a.heider@gmail.com>2023-04-08 08:38:54 +0200
commit35f4ef76e0c88b690ec55f26aed072c4c5989eff (patch)
treec5b36bb3b16488c4546c3c283b8a6020e3966143 /libs/glib2/Makefile
parent565866a47210c9711c29173052063779b6d3bcfc (diff)
treewide: refactor to use PKG_BUILD_FLAGS:=gc-sections
See commit da370098 "treewide: add support for "gc-sections" in PKG_BUILD_FLAGS" on the main repository. Note: This only touches packages which use all three parts (-ffunction-sections, -fdata-sections and -Wl,--gc-sections) enabled by this build flag. Some packages only use a subset, and these are left unchanged for now. Signed-off-by: Andre Heider <a.heider@gmail.com>
Diffstat (limited to 'libs/glib2/Makefile')
-rw-r--r--libs/glib2/Makefile4
1 files changed, 1 insertions, 3 deletions
diff --git a/libs/glib2/Makefile b/libs/glib2/Makefile
index 5493e5e69..226242dc5 100644
--- a/libs/glib2/Makefile
+++ b/libs/glib2/Makefile
@@ -24,6 +24,7 @@ PKG_BUILD_DIR:=$(BUILD_DIR)/glib-$(PKG_VERSION)
HOST_BUILD_DIR:=$(BUILD_DIR_HOST)/glib-$(PKG_VERSION)
PKG_CONFIG_DEPENDS:=CONFIG_BUILD_NLS
PKG_FORTIFY_SOURCE:=0
+PKG_BUILD_FLAGS:=gc-sections
include $(INCLUDE_DIR)/host-build.mk
include $(INCLUDE_DIR)/package.mk
@@ -42,9 +43,6 @@ define Package/glib2/description
The GLib library of C routines
endef
-TARGET_CFLAGS += -ffunction-sections -fdata-sections
-TARGET_LDFLAGS += -Wl,--gc-sections
-
COMP_ARGS= \
-Dselinux=disabled \
-Dlibmount=disabled \