aboutsummaryrefslogtreecommitdiff
path: root/libs/giflib
diff options
context:
space:
mode:
authorTed Hess <thess@kitschensync.net>2015-06-11 16:17:41 -0400
committerTed Hess <thess@kitschensync.net>2015-06-11 16:17:41 -0400
commit99263ff5734fef8525fc055f69721b6e041af7f3 (patch)
tree5bc0dbcdd22b4a3d2e598f0b9a849a12f4c1362a /libs/giflib
parentd5c18252d4c4fe01ff582c17ce62721307c9cd26 (diff)
giflib: Import from oldpackages, update to latest version, add myself as maintainer
Signed-off-by: Ted Hess <thess@kitschensync.net>
Diffstat (limited to 'libs/giflib')
-rw-r--r--libs/giflib/Makefile61
1 files changed, 61 insertions, 0 deletions
diff --git a/libs/giflib/Makefile b/libs/giflib/Makefile
new file mode 100644
index 000000000..efeabee68
--- /dev/null
+++ b/libs/giflib/Makefile
@@ -0,0 +1,61 @@
+#
+# Copyright (C) 2006-2015 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+include $(TOPDIR)/rules.mk
+
+PKG_NAME:=giflib
+PKG_VERSION:=5.1.1
+PKG_RELEASE:=1
+
+PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
+PKG_SOURCE_URL:=@SF/giflib
+PKG_MD5SUM:=1c39333192712788c6568c78a949f13e
+
+PKG_MAINTAINER:=Ted Hess <thess@kitschensync.net>
+
+PKG_LICENSE:=MIT
+PKG_LICENSE_FILES:=COPYING
+
+PKG_FIXUP:=autoreconf
+PKG_REMOVE_FILES:=autogen.sh aclocal.m4
+
+include $(INCLUDE_DIR)/package.mk
+
+define Package/giflib
+ SECTION:=libs
+ CATEGORY:=Libraries
+ TITLE:=GIF libraries
+ URL:=http://sourceforge.net/projects/giflib
+endef
+
+define Package/giflib/description
+ giflib is a library for reading and writing gif images.
+ It is API and ABI compatible with libungif which was in wide use while
+ the LZW compression algorithm was patented.
+endef
+
+TARGET_CFLAGS += $(FPIC)
+CONFIGURE_ARGS += --enable-x11=no
+
+define Build/Compile
+ $(MAKE) -C $(PKG_BUILD_DIR)
+endef
+
+define Build/InstallDev
+ $(INSTALL_DIR) $(1)/usr/{lib,include}
+ $(CP) $(PKG_BUILD_DIR)/lib/.libs/lib*so* $(1)/usr/lib
+ $(CP) $(PKG_BUILD_DIR)/lib/.libs/libgif.a $(1)/usr/lib
+ $(CP) $(PKG_BUILD_DIR)/lib/libgif.la $(1)/usr/lib
+ $(CP) $(PKG_BUILD_DIR)/lib/*.h $(1)/usr/include/
+endef
+
+define Package/giflib/install
+ $(INSTALL_DIR) $(1)/usr/lib
+ $(CP) $(PKG_BUILD_DIR)/lib/.libs/lib*so* $(1)/usr/lib/
+endef
+
+$(eval $(call BuildPackage,giflib))