aboutsummaryrefslogtreecommitdiff
path: root/libs/giflib
diff options
context:
space:
mode:
authorSteven Barth <steven@midlink.org>2014-07-29 08:59:44 +0200
committerSteven Barth <steven@midlink.org>2014-07-29 09:00:15 +0200
commit0cb8ba433a0c8385f5c7b05a0f862102bfe59868 (patch)
tree99db9771da48974645223745753b55b44c562060 /libs/giflib
parentec6d0154a729297490d01fec918b893f548c303c (diff)
tiff, giflib: removed for being abandoned
Signed-off-by: Steven Barth <steven@midlink.org>
Diffstat (limited to 'libs/giflib')
-rw-r--r--libs/giflib/Makefile59
1 files changed, 0 insertions, 59 deletions
diff --git a/libs/giflib/Makefile b/libs/giflib/Makefile
deleted file mode 100644
index e703f45f3..000000000
--- a/libs/giflib/Makefile
+++ /dev/null
@@ -1,59 +0,0 @@
-#
-# Copyright (C) 2006-2014 OpenWrt.org
-#
-# This is free software, licensed under the GNU General Public License v2.
-# See /LICENSE for more information.
-#
-
-include $(TOPDIR)/rules.mk
-
-PKG_NAME:=giflib
-PKG_VERSION:=5.1.0
-PKG_RELEASE:=1
-
-PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
-PKG_SOURCE_URL:=@SF/giflib
-PKG_MD5SUM:=c7e9f1c10b755ab955156d4c1ac7fc5d
-
-PKG_LICENSE:=MIT
-PKG_LICENSE_FILES:=COPYING
-
-PKG_FIXUP:=autoreconf
-PKG_REMOVE_FILES:=autogen.sh aclocal.m4
-
-include $(INCLUDE_DIR)/package.mk
-
-define Package/giflib
- SECTION:=libs
- CATEGORY:=Libraries
- TITLE:=GIF libraries
- URL:=http://sourceforge.net/projects/giflib
-endef
-
-define Package/giflib/description
- giflib is a library for reading and writing gif images.
- It is API and ABI compatible with libungif which was in wide use while
- the LZW compression algorithm was patented.
-endef
-
-TARGET_CFLAGS += $(FPIC)
-CONFIGURE_ARGS += --enable-x11=no
-
-define Build/Compile
- $(MAKE) -C $(PKG_BUILD_DIR)
-endef
-
-define Build/InstallDev
- $(INSTALL_DIR) $(1)/usr/{lib,include}
- $(CP) $(PKG_BUILD_DIR)/lib/.libs/lib*so* $(1)/usr/lib
- $(CP) $(PKG_BUILD_DIR)/lib/.libs/libgif.a $(1)/usr/lib
- $(CP) $(PKG_BUILD_DIR)/lib/libgif.la $(1)/usr/lib
- $(CP) $(PKG_BUILD_DIR)/lib/*.h $(1)/usr/include/
-endef
-
-define Package/giflib/install
- $(INSTALL_DIR) $(1)/usr/lib
- $(CP) $(PKG_BUILD_DIR)/lib/.libs/lib*so* $(1)/usr/lib/
-endef
-
-$(eval $(call BuildPackage,giflib))