aboutsummaryrefslogtreecommitdiff
path: root/libs/getdns
diff options
context:
space:
mode:
authorHarris K Kusuma <igharris.kk@gmail.com>2021-02-01 18:06:09 +0700
committerHarris K Kusuma <igharris.kk@gmail.com>2021-02-01 18:38:48 +0700
commit342526f14203f79396d83130f0a368319f627e8b (patch)
tree4c6187d13839b21b239b1a107f0983153b7b9c63 /libs/getdns
parentc8e2d56a5a9f3a2214a8c421ce6b8dfe957311df (diff)
getdns: Fix TLS V1.3 Ciphersuites option in Stubby
Description : Fix typo in CMAKE getdns included files, so Stubby can use TLS v1.3 with chipersuites options ON. This solve issue that's written in here : https://github.com/getdnsapi/stubby/issues/240 https://github.com/getdnsapi/stubby/issues/257 Signed-off-by: Harris K Kusuma <igharris.kk@gmail.com>
Diffstat (limited to 'libs/getdns')
-rw-r--r--libs/getdns/Makefile2
-rw-r--r--libs/getdns/patches/030-typo-cmake-fix-stubby.patch13
2 files changed, 14 insertions, 1 deletions
diff --git a/libs/getdns/Makefile b/libs/getdns/Makefile
index b8adde8d5..476368399 100644
--- a/libs/getdns/Makefile
+++ b/libs/getdns/Makefile
@@ -6,7 +6,7 @@ include $(TOPDIR)/rules.mk
PKG_NAME:=getdns
PKG_VERSION:=1.6.0
-PKG_RELEASE:=3
+PKG_RELEASE:=4
PKG_LICENSE:=BSD-3-Clause
PKG_LICENSE_FILES:=LICENSE
diff --git a/libs/getdns/patches/030-typo-cmake-fix-stubby.patch b/libs/getdns/patches/030-typo-cmake-fix-stubby.patch
new file mode 100644
index 000000000..f3fe11f73
--- /dev/null
+++ b/libs/getdns/patches/030-typo-cmake-fix-stubby.patch
@@ -0,0 +1,13 @@
+--- a/cmake/include/cmakeconfig.h.in
++++ b/cmake/include/cmakeconfig.h.in
+@@ -91,8 +91,8 @@
+ #cmakedefine HAVE_OPENSSL_VERSION 1
+
+ #cmakedefine HAVE_SSL_CTX_DANE_ENABLE 1
+-#cmakedefine HAVE_SSL_CTX_SET_CIPHERSUITS 1
+-#cmakedefine HAVE_SSL_SET_CIPHERSUITS 1
++#cmakedefine HAVE_SSL_CTX_SET_CIPHERSUITES 1
++#cmakedefine HAVE_SSL_SET_CIPHERSUITES 1
+
+ #cmakedefine HAVE_OPENSSL_INIT_CRYPTO 1
+