aboutsummaryrefslogtreecommitdiff
path: root/libs/getdns
diff options
context:
space:
mode:
authorJonathan G. Underwood <jonathan.underwood@gmail.com>2021-02-07 13:40:36 +0000
committerJonathan G. Underwood <jonathan.underwood@gmail.com>2021-02-07 13:44:47 +0000
commit24c02c728fdc4def87e5dce4121f0db6299786c5 (patch)
tree8cab338d89b47e3ff5ff68f6cfa617ba512cb523 /libs/getdns
parentf4dd722c3fb57c0d365d4a21a3a7fe8fc04dddd9 (diff)
getdns: disable static linking of getdns utilities
This fixes issue #13361. Signed-off-by: Jonathan G. Underwood <jonathan.underwood@gmail.com>
Diffstat (limited to 'libs/getdns')
-rw-r--r--libs/getdns/Makefile7
1 files changed, 6 insertions, 1 deletions
diff --git a/libs/getdns/Makefile b/libs/getdns/Makefile
index 476368399..360fb8297 100644
--- a/libs/getdns/Makefile
+++ b/libs/getdns/Makefile
@@ -6,7 +6,7 @@ include $(TOPDIR)/rules.mk
PKG_NAME:=getdns
PKG_VERSION:=1.6.0
-PKG_RELEASE:=4
+PKG_RELEASE:=5
PKG_LICENSE:=BSD-3-Clause
PKG_LICENSE_FILES:=LICENSE
@@ -64,6 +64,11 @@ CMAKE_OPTIONS += -DUSE_LIBIDN2=$(if $(CONFIG_GETDNS_ENABLE_IDN_LIBIDN2),ON,OFF)
# the test for libbsd.
CMAKE_OPTIONS += -DBSD_LIBRARY=OFF
+# Disable static linking to ensure that utility programs such as getdns_query
+# don't end up as large statically linked binaries.
+CMAKE_OPTIONS += -DENABLE_STATIC=OFF
+CMAKE_OPTIONS += -DENABLE_SHARED=ON # This is the default
+
define Package/getdns/install
$(INSTALL_DIR) $(1)/usr/lib
$(CP) $(PKG_INSTALL_DIR)/usr/lib/libgetdns.so.* $(1)/usr/lib/