aboutsummaryrefslogtreecommitdiff
path: root/libs/getdns
diff options
context:
space:
mode:
authorGuo Li <uxgood.org@gmail.com>2018-09-10 11:59:23 +0800
committerYousong Zhou <yszhou4tech@gmail.com>2018-09-25 17:11:17 +0800
commit035b22b2085c1dc5f5788a941a44f69de757826b (patch)
treead7eac4143fd4289914ec79bd9c23c6458c50d32 /libs/getdns
parent8365744b80c1c0c57fabe199aaa08e6bacef8063 (diff)
getdns: remove libbsd dependency
Signed-off-by: Guo Li <uxgood.org@gmail.com>
Diffstat (limited to 'libs/getdns')
-rw-r--r--libs/getdns/Makefile4
1 files changed, 3 insertions, 1 deletions
diff --git a/libs/getdns/Makefile b/libs/getdns/Makefile
index d724f739a..2578659de 100644
--- a/libs/getdns/Makefile
+++ b/libs/getdns/Makefile
@@ -36,7 +36,7 @@ define Package/getdns
SECTION:=libs
CATEGORY:=Libraries
TITLE+= (library)
- DEPENDS+= +libopenssl +libbsd +!GETDNS_ENABLE_STUB_ONLY:libunbound +GETDNS_ENABLE_IDN_LIBIDN2:libidn2
+ DEPENDS+= +libopenssl +!GETDNS_ENABLE_STUB_ONLY:libunbound +GETDNS_ENABLE_IDN_LIBIDN2:libidn2
MENU:=1
endef
@@ -55,6 +55,8 @@ CONFIGURE_ARGS += \
$(if $(CONFIG_GETDNS_ENABLE_IDN_LIBIDN2), , --without-libidn2 ) \
--with-ssl="$(STAGING_DIR)/usr" \
+CONFIGURE_VARS += LIBBSD_LIBS=-lc
+
define Build/InstallDev
$(INSTALL_DIR) $(1)/usr/include/getdns/
$(CP) $(PKG_INSTALL_DIR)/usr/include/getdns/getdns*.h $(1)/usr/include/getdns/