aboutsummaryrefslogtreecommitdiff
path: root/libs/getdns/Makefile
diff options
context:
space:
mode:
authorDavid Mora <iamperson347+public@gmail.com>2018-04-17 18:10:59 -0400
committerDavid Mora <iamperson347+public@gmail.com>2018-04-17 18:10:59 -0400
commitcefe7738b5ec7e979f701ce43f7be12975d3fd89 (patch)
tree9b9b00fc2cd959191a841a3b2b476a621bdb050f /libs/getdns/Makefile
parentb1bd165886ee260b252eb05c55b87349a7b72d9f (diff)
getdns: Package update to replace libidn support with libidn2
Package update to replace libidn support with libidn2 Signed-off-by: David Mora <iamperson347+public@gmail.com>
Diffstat (limited to 'libs/getdns/Makefile')
-rw-r--r--libs/getdns/Makefile10
1 files changed, 5 insertions, 5 deletions
diff --git a/libs/getdns/Makefile b/libs/getdns/Makefile
index 74027fd25..b9245fbe9 100644
--- a/libs/getdns/Makefile
+++ b/libs/getdns/Makefile
@@ -6,7 +6,7 @@ include $(TOPDIR)/rules.mk
PKG_NAME:=getdns
PKG_VERSION:=1.4.1
-PKG_RELEASE:=1
+PKG_RELEASE:=2
PKG_LICENSE:=BSD-3-Clause
PKG_LICENSE_FILES:=LICENSE
@@ -22,7 +22,7 @@ PKG_INSTALL:=1
PKG_CONFIG_DEPENDS:= \
CONFIG_GETDNS_ENABLE_STUB_ONLY \
- CONFIG_GETDNS_ENABLE_IDN_LIBIDN
+ CONFIG_GETDNS_ENABLE_IDN_LIBIDN2
include $(INCLUDE_DIR)/package.mk
@@ -36,7 +36,7 @@ define Package/getdns
SECTION:=libs
CATEGORY:=Libraries
TITLE+= (library)
- DEPENDS+= +libopenssl +!GETDNS_ENABLE_STUB_ONLY:libunbound +GETDNS_ENABLE_IDN_LIBIDN:libidn
+ DEPENDS+= +libopenssl +!GETDNS_ENABLE_STUB_ONLY:libunbound +GETDNS_ENABLE_IDN_LIBIDN2:libidn2
MENU:=1
endef
@@ -51,8 +51,8 @@ endef
CONFIGURE_ARGS += \
$(if $(CONFIG_GETDNS_ENABLE_STUB_ONLY), --enable-stub-only, ) \
- $(if $(CONFIG_GETDNS_ENABLE_IDN_LIBIDN), , --without-libidn ) \
- --without-libidn2 \
+ --without-libidn \
+ $(if $(CONFIG_GETDNS_ENABLE_IDN_LIBIDN2), , --without-libidn2 ) \
--with-ssl="$(STAGING_DIR)/usr" \
define Build/InstallDev