aboutsummaryrefslogtreecommitdiff
path: root/libs/faad2
diff options
context:
space:
mode:
authorDaniel Engberg <daniel.engberg.lists@pyret.net>2017-08-07 14:03:22 +0200
committerDaniel Engberg <daniel.engberg.lists@pyret.net>2017-08-07 14:31:04 +0200
commitf47809da4486f7046846766b9ec87894d534cb4e (patch)
tree4c4618ff88a82c9f5d88b0275db4a680500ea1dc /libs/faad2
parent4abda067013ed9f72004aee06de2d1bab7f9f3b4 (diff)
libs/faad2: Update to 2.8.1
* Switch back to upstream repo * Follow the same configuration style as ffmpeg and mpg123 for using float vs fixed point codepaths. * Remove unneeded cpp variables (musl provides C99 math library) Signed-off-by: Daniel Engberg <daniel.engberg.lists@pyret.net>
Diffstat (limited to 'libs/faad2')
-rw-r--r--libs/faad2/Config.in12
-rw-r--r--libs/faad2/Makefile30
2 files changed, 11 insertions, 31 deletions
diff --git a/libs/faad2/Config.in b/libs/faad2/Config.in
deleted file mode 100644
index 00336766f..000000000
--- a/libs/faad2/Config.in
+++ /dev/null
@@ -1,12 +0,0 @@
-config FAAD2_ALWAYS_USE_FLOATING_POINT
- depends on PACKAGE_libfaad2
- bool "Build FAAD2 to use floating-point math even if using soft floats."
- default n
- help
- By default, libfaad2 will be built to use fixed point rather
- than floating point math if emulated floating point operations
- are being used. (See the CONFIG_SOFT_FLOAT option.) Set this
- option if you would like to use floating point math regardless
- of whether floating point emulation is in use.
-
- For the best real-time decoding ability, leave this option off.
diff --git a/libs/faad2/Makefile b/libs/faad2/Makefile
index 01b3e0c55..f315b5382 100644
--- a/libs/faad2/Makefile
+++ b/libs/faad2/Makefile
@@ -6,18 +6,14 @@
include $(TOPDIR)/rules.mk
PKG_NAME:=faad2
-PKG_VERSION:=2.8.0~cvs20161113
+PKG_VERSION:=2.8.1
PKG_RELEASE:=1
-PKG_SOURCE:=$(PKG_NAME)_$(PKG_VERSION).orig.tar.xz
-PKG_SOURCE_URL:=http://ftp.debian.org/debian/pool/main/f/$(PKG_NAME)
-PKG_HASH:=de34bce327eac8a89cd58b7d44dfb58988033de6fda0ab9582ed0585fc3fd07e
+PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
+PKG_SOURCE_URL:=@SF/faac/faad2-src/$(PKG_NAME)-2.8.0
+PKG_HASH:=f4042496f6b0a60f5ded6acd11093230044ef8a2fd965360c1bbd5b58780933d
PKG_MAINTAINER:=Ted Hess <thess@kitschensync.net>
-PKG_CONFIG_DEPENDS := \
- CONFIG_SOFT_FLOAT \
- CONFIG_FAAD2_ALWAYS_USE_FLOATING_POINT
-
PKG_FIXUP:=autoreconf
PKG_INSTALL:=1
@@ -56,10 +52,6 @@ $(call Package/faad2/Default)
MENU:=1
endef
-define Package/libfaad2/config
- source "$(SOURCE)/Config.in"
-endef
-
define Package/libfaad2/description
$(call Package/faad2/Default/description)
This package contains the library.
@@ -68,14 +60,14 @@ endef
TARGET_CFLAGS += $(FPIC)
CONFIGURE_ARGS+= --without-xmms
-# Use fixed point math, if we're using soft floats, and the user didn't
-# specifically ask to use floats anyways.
-#ifeq ($(CONFIG_SOFT_FLOAT)-$(CONFIG_FAAD2_ALWAYS_USE_FLOATING_POINT),y-)
-TARGET_CFLAGS+= -DFIXED_POINT
-CONFIGURE_ARGS+= -nfp
-#endif
+ifeq ($(CONFIG_SOFT_FLOAT),y)
+ TARGET_CFLAGS+= -DFIXED_POINT
+ CONFIGURE_ARGS+= -nfp
+endif
-CONFIGURE_VARS+= CPPFLAGS="-fno-builtin-cos -fno-builtin-sin -fno-builtin-log"
+ifeq ($(CONFIG_USE_UCLIBC),y)
+ CONFIGURE_VARS+= CPPFLAGS="-fno-builtin-cos -fno-builtin-sin -fno-builtin-log"
+endif
define Build/InstallDev
$(INSTALL_DIR) $(1)/usr/include