aboutsummaryrefslogtreecommitdiff
path: root/libs/faad2
diff options
context:
space:
mode:
authorTed Hess <thess@kitschensync.net>2017-05-20 11:43:17 -0400
committerTed Hess <thess@kitschensync.net>2017-05-20 11:43:17 -0400
commit855150a8f98b9eb5903f04570a32563ef6585873 (patch)
tree22523d01a58763743619f4f9c5340cd5fba562dc /libs/faad2
parent3c94c75d3c4f60c69ea0d4d144203fc4d249b22c (diff)
faad2: Upgrade to lastest Debian patches, cleanup build procs
Signed-off-by: Ted Hess <thess@kitschensync.net>
Diffstat (limited to 'libs/faad2')
-rw-r--r--libs/faad2/Makefile48
1 files changed, 16 insertions, 32 deletions
diff --git a/libs/faad2/Makefile b/libs/faad2/Makefile
index f6bed3d95..01b3e0c55 100644
--- a/libs/faad2/Makefile
+++ b/libs/faad2/Makefile
@@ -1,6 +1,4 @@
#
-# Copyright (C) 2008-2014 OpenWrt.org
-#
# This is free software, licensed under the GNU General Public License v2.
# See /LICENSE for more information.
#
@@ -8,12 +6,12 @@
include $(TOPDIR)/rules.mk
PKG_NAME:=faad2
-PKG_VERSION:=2.7
-PKG_RELEASE:=3
+PKG_VERSION:=2.8.0~cvs20161113
+PKG_RELEASE:=1
-PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
-PKG_SOURCE_URL:=@SF/faac
-PKG_MD5SUM:=4c332fa23febc0e4648064685a3d4332
+PKG_SOURCE:=$(PKG_NAME)_$(PKG_VERSION).orig.tar.xz
+PKG_SOURCE_URL:=http://ftp.debian.org/debian/pool/main/f/$(PKG_NAME)
+PKG_HASH:=de34bce327eac8a89cd58b7d44dfb58988033de6fda0ab9582ed0585fc3fd07e
PKG_MAINTAINER:=Ted Hess <thess@kitschensync.net>
PKG_CONFIG_DEPENDS := \
@@ -25,15 +23,6 @@ PKG_INSTALL:=1
include $(INCLUDE_DIR)/package.mk
-TARGET_CFLAGS += $(FPIC)
-
-# Use fixed point math, if we're using soft floats, and the user didn't
-# specifically ask to use floats anyways.
-ifeq ($(CONFIG_SOFT_FLOAT)-$(CONFIG_FAAD2_ALWAYS_USE_FLOATING_POINT),y-)
-TARGET_CFLAGS+= -DFIXED_POINT
-FAAD2_CONFIG_OPTS= --without-fp -nfp
-endif
-
define Package/faad2/Default
URL:=http://www.audiocoding.com/faad2.html
TITLE:=Freeware Advanced Audio Decoder
@@ -76,22 +65,17 @@ $(call Package/faad2/Default/description)
This package contains the library.
endef
-define Build/Configure
- # This replacement were do according to many comments on the web because of gcc 3.4.5 version (.6 included).-
- # which doesn't recognices the -iquote parameter to AM_CFLAGS
- ($(SED) 's,-iquote $$$$(top_srcdir),-I$$$$(top_srcdir),g' $(PKG_BUILD_DIR)/libfaad/Makefile.am; \
- $(SED) 's,-iquote $$$$(top_srcdir),-I$$$$(top_srcdir),g' $(PKG_BUILD_DIR)/libfaad/Makefile.in);
- (cd $(PKG_BUILD_DIR); rm -rf config.{cache,status}; \
- autoreconf -vif \
- );
- $(call Build/Configure/Default, \
- --with-mp4v2 \
- $(FAAD2_CONFIG_OPTS) \
- --without-xmms \
- , \
- FAAD2_CPPFLAGS="-fno-builtin-cos -fno-builtin-sin -fno-builtin-log" \
- )
-endef
+TARGET_CFLAGS += $(FPIC)
+CONFIGURE_ARGS+= --without-xmms
+
+# Use fixed point math, if we're using soft floats, and the user didn't
+# specifically ask to use floats anyways.
+#ifeq ($(CONFIG_SOFT_FLOAT)-$(CONFIG_FAAD2_ALWAYS_USE_FLOATING_POINT),y-)
+TARGET_CFLAGS+= -DFIXED_POINT
+CONFIGURE_ARGS+= -nfp
+#endif
+
+CONFIGURE_VARS+= CPPFLAGS="-fno-builtin-cos -fno-builtin-sin -fno-builtin-log"
define Build/InstallDev
$(INSTALL_DIR) $(1)/usr/include