aboutsummaryrefslogtreecommitdiff
path: root/libs/expat
diff options
context:
space:
mode:
authorDaniel Golle <daniel@makrotopia.org>2021-11-24 01:33:20 +0000
committerDaniel Golle <daniel@makrotopia.org>2021-11-24 01:34:23 +0000
commitca21bbf2edd64fffd044e0d6caf6975243a3fa4b (patch)
treee86051b5e122688785f5bf294e290b2e287f6473 /libs/expat
parent08878970e9bcde8b02165f2d305d522d2f382e0e (diff)
expat: add host build
mesa in the video feed requires expat/host. Provide host build to allow mesa to build. Signed-off-by: Daniel Golle <daniel@makrotopia.org>
Diffstat (limited to 'libs/expat')
-rw-r--r--libs/expat/Makefile2
1 files changed, 2 insertions, 0 deletions
diff --git a/libs/expat/Makefile b/libs/expat/Makefile
index 7e8baf4e7..4bacb8e91 100644
--- a/libs/expat/Makefile
+++ b/libs/expat/Makefile
@@ -21,6 +21,7 @@ PKG_CPE_ID:=cpe:/a:libexpat:expat
CMAKE_INSTALL:=1
include $(INCLUDE_DIR)/package.mk
+include $(INCLUDE_DIR)/host-build.mk
include $(INCLUDE_DIR)/cmake.mk
define Package/libexpat
@@ -51,4 +52,5 @@ define Package/libexpat/install
$(CP) $(PKG_INSTALL_DIR)/usr/lib/libexpat.so.* $(1)/usr/lib/
endef
+$(eval $(call HostBuild))
$(eval $(call BuildPackage,libexpat))