aboutsummaryrefslogtreecommitdiff
path: root/libs/expat
diff options
context:
space:
mode:
authorMichael Heimpold <michael.heimpold@i2se.com>2018-09-03 13:36:08 +0200
committerMichael Heimpold <michael.heimpold@i2se.com>2018-09-03 13:39:04 +0200
commit76b915c2494b5508b1526adc905f9776c8a02db3 (patch)
tree94918d25fddc2ffe14d05279f7c346a79e6eb159 /libs/expat
parenta8108500dc08634a2832ba7d9d449b2227296400 (diff)
expat: fix host build issue with docbook
Additionally to the fix issued for #6923, we need to disable the docbook usage also for the host build. This prevents the following error: checking for docbook2man... docbook2man configure: error: Your local docbook2man was found to work with SGML rather than XML. Please install docbook2X and use variable DOCBOOK_TO_MAN to point configure to command docbook2x-man of docbook2X. Or use DOCBOOK_TO_MAN="xmlto man --skip-validation" if you have xmlto around. You can also configure using --without-docbook if you can do without a man page for xmlwf. Signed-off-by: Michael Heimpold <michael.heimpold@i2se.com>
Diffstat (limited to 'libs/expat')
-rw-r--r--libs/expat/Makefile3
1 files changed, 3 insertions, 0 deletions
diff --git a/libs/expat/Makefile b/libs/expat/Makefile
index 3f1d71e09..52e713336 100644
--- a/libs/expat/Makefile
+++ b/libs/expat/Makefile
@@ -44,6 +44,9 @@ CONFIGURE_ARGS += \
--enable-static \
--without-docbook
+HOST_CONFIGURE_ARGS += \
+ --without-docbook
+
define Host/Install
$(MAKE) -C $(HOST_BUILD_DIR) install
endef