aboutsummaryrefslogtreecommitdiff
path: root/libs/expat
diff options
context:
space:
mode:
authorRosen Penev <rosenp@gmail.com>2020-07-08 14:07:34 -0700
committerRosen Penev <rosenp@gmail.com>2020-07-08 14:09:11 -0700
commit0de5f3b5d020f2ae920bb9f004999966dc83586a (patch)
tree9b9c71b607f9289c17d22b8c19cc4e48c7b33ede /libs/expat
parente576e59df408acb5844174900e4a42eb18890aca (diff)
expat: fix compilation with doc2man
Even though doc2man is explicitly disabled, it is only for the target. Split out the options to a separate variable. Signed-off-by: Rosen Penev <rosenp@gmail.com>
Diffstat (limited to 'libs/expat')
-rw-r--r--libs/expat/Makefile5
1 files changed, 4 insertions, 1 deletions
diff --git a/libs/expat/Makefile b/libs/expat/Makefile
index f3f421249..90b6c1404 100644
--- a/libs/expat/Makefile
+++ b/libs/expat/Makefile
@@ -36,7 +36,7 @@ define Package/libexpat/description
A fast, non-validating, stream-oriented XML parsing library.
endef
-CMAKE_OPTIONS += \
+OPTIONS += \
-DDOCBOOK_TO_MAN=OFF \
-DEXPAT_BUILD_TOOLS=OFF \
-DEXPAT_BUILD_EXAMPLES=OFF \
@@ -48,6 +48,9 @@ CMAKE_OPTIONS += \
-DEXPAT_NS=OFF \
-DEXPAT_DEV_URANDOM=OFF
+CMAKE_OPTIONS += $(OPTIONS)
+CMAKE_HOST_OPTIONS += $(OPTIONS)
+
define Package/libexpat/install
$(INSTALL_DIR) $(1)/usr/lib
$(CP) $(PKG_INSTALL_DIR)/usr/lib/libexpat.so.* $(1)/usr/lib/