aboutsummaryrefslogtreecommitdiff
path: root/libs/expat/Makefile
diff options
context:
space:
mode:
authorRosen Penev <rosenp@gmail.com>2021-10-18 16:10:33 -0700
committerRosen Penev <rosenp@gmail.com>2021-10-19 13:16:18 -0700
commit5bf74f2ad434841bfe9c3013e55556c0005e74cb (patch)
treeec180a50bf2cb2cbf245364929c97c295a37b697 /libs/expat/Makefile
parent575776cfa59e45940b01e89cc61d404127194f94 (diff)
expat: don't build host libs
tools/expat is actually what's used by the various packages that supposedly depend on expat/host. Signed-off-by: Rosen Penev <rosenp@gmail.com>
Diffstat (limited to 'libs/expat/Makefile')
-rw-r--r--libs/expat/Makefile7
1 files changed, 1 insertions, 6 deletions
diff --git a/libs/expat/Makefile b/libs/expat/Makefile
index ba91114c5..7e8baf4e7 100644
--- a/libs/expat/Makefile
+++ b/libs/expat/Makefile
@@ -20,7 +20,6 @@ PKG_CPE_ID:=cpe:/a:libexpat:expat
CMAKE_INSTALL:=1
-include $(INCLUDE_DIR)/host-build.mk
include $(INCLUDE_DIR)/package.mk
include $(INCLUDE_DIR)/cmake.mk
@@ -35,7 +34,7 @@ define Package/libexpat/description
A fast, non-validating, stream-oriented XML parsing library.
endef
-OPTIONS += \
+CMAKE_OPTIONS += \
-DDOCBOOK_TO_MAN=OFF \
-DEXPAT_BUILD_TOOLS=OFF \
-DEXPAT_BUILD_EXAMPLES=OFF \
@@ -47,13 +46,9 @@ OPTIONS += \
-DEXPAT_NS=OFF \
-DEXPAT_DEV_URANDOM=OFF
-CMAKE_OPTIONS += $(OPTIONS)
-CMAKE_HOST_OPTIONS += $(OPTIONS)
-
define Package/libexpat/install
$(INSTALL_DIR) $(1)/usr/lib
$(CP) $(PKG_INSTALL_DIR)/usr/lib/libexpat.so.* $(1)/usr/lib/
endef
-$(eval $(call HostBuild))
$(eval $(call BuildPackage,libexpat))