aboutsummaryrefslogtreecommitdiff
path: root/libs/elektra/Makefile
diff options
context:
space:
mode:
authorHarald Geyer <harald@ccbib.org>2016-05-09 18:11:57 +0000
committerHarald Geyer <harald@ccbib.org>2016-05-11 20:20:41 +0000
commitb7d9ab4cbae04dd35d029e5120401af4aaa7a0f5 (patch)
tree7c1e3db19507a990eea4c43f16dd36cc8f2090e8 /libs/elektra/Makefile
parent2f86c894de96e30d925450bea22eb59adea5eeec (diff)
elektra: Update to 0.8.16
Notable changes: Add -DCMAKE_CXX_FLAGS="-DELEKTRA_SHARED" to work around an upstream bug (already fixed) in the Makefile. Signed-off-by: Harald Geyer <harald@ccbib.org>
Diffstat (limited to 'libs/elektra/Makefile')
-rw-r--r--libs/elektra/Makefile19
1 files changed, 11 insertions, 8 deletions
diff --git a/libs/elektra/Makefile b/libs/elektra/Makefile
index 5cfaae719..a03ae376c 100644
--- a/libs/elektra/Makefile
+++ b/libs/elektra/Makefile
@@ -14,11 +14,11 @@ PKG_MAINTAINER:=Harald Geyer <harald@ccbib.org>
PKG_NAME:=elektra
PKG_LICENSE:=BSD-3-Clause
PKG_LICENSE_FILES:=doc/COPYING
-PKG_VERSION:=0.8.15
+PKG_VERSION:=0.8.16
PKG_RELEASE:=1
# Use this for official releasees
-PKG_MD5SUM:=33ec1e5982fb7fbd8893bf7b579b80f0
+PKG_MD5SUM:=ef0c138b4a4fda017aa8bb6f812671ce
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
PKG_SOURCE_URL:=http://ftp.libelektra.org/ftp/elektra/releases
@@ -97,9 +97,9 @@ define Package/libelektra-plugins
endef
define CONTENT_ELEKTRA_PLUGINS_TEXT
-ccode conditionals csvstorage enum filecheck glob hexcode hidden hosts
-iconv keytometa line lineendings list mathcheck network null path
-simpleini syslog uname validation
+ccode conditionals csvstorage curlget enum filecheck glob hexcode hidden
+hosts iconv keytometa line lineendings list mathcheck network null path
+profile shell syslog uname validation
endef
CONTENT_ELEKTRA_PLUGINS = $(strip $(CONTENT_ELEKTRA_PLUGINS_TEXT))
@@ -233,7 +233,7 @@ define Package/libelektra-extra
DEPENDS:=+libelektra-core
endef
-CONTENT_ELEKTRA_EXTRA:=constants counter error fstab logchange rename timeofday tracer
+CONTENT_ELEKTRA_EXTRA:=constants counter dpkg error fstab logchange rename timeofday tracer
define Package/libelektra-extra/description
$(call Package/libelektra/Default-description)
@@ -252,7 +252,8 @@ CMAKE_OPTIONS = \
-DBUILD_TESTING=OFF \
-DKDB_DEFAULT_RESOLVER=resolver_fm_pb_b \
-DKDB_DEFAULT_STORAGE=ini \
- -DPLUGINS="ALL;-crypto_gcrypt"
+ -DCMAKE_CXX_FLAGS="-DELEKTRA_SHARED" \
+ -DPLUGINS="ALL"
CMAKE_HOST_OPTIONS = \
-DCMAKE_SKIP_RPATH=FALSE \
@@ -280,6 +281,8 @@ define Package/libelektra-core/install
$(CP) $(PKG_INSTALL_DIR)/usr/lib/libelektra-ni.so $(1)/usr/lib/
$(CP) $(PKG_INSTALL_DIR)/usr/lib/libelektra-ini.so $(1)/usr/lib/
$(CP) $(PKG_INSTALL_DIR)/usr/lib/libelektra-sync.so $(1)/usr/lib/
+ $(CP) $(PKG_INSTALL_DIR)/usr/lib/libelektra-storage.so $(1)/usr/lib/
+ $(CP) $(PKG_INSTALL_DIR)/usr/lib/libelektra-resolver.so $(1)/usr/lib/
endef
define Package/elektra-kdb/install
@@ -315,7 +318,7 @@ endef
define Package/libelektra-crypto/install
$(INSTALL_DIR) $(1)/usr/lib/
- $(CP) $(PKG_INSTALL_DIR)/usr/lib/libelektra-crypto* $(1)/usr/lib/
+ $(CP) $(PKG_INSTALL_DIR)/usr/lib/libelektra-crypto_openssl.so $(1)/usr/lib/
endef
define Package/libelektra-dbus/install