aboutsummaryrefslogtreecommitdiff
path: root/libs/easyloggingpp
diff options
context:
space:
mode:
authorVolker Christian <me@vchrist.at>2023-07-18 15:28:49 +0200
committerTianling Shen <cnsztl@gmail.com>2023-07-20 14:52:43 +0800
commit2611e7c798c2cc27f0cd1ffee410787e1b77eb7d (patch)
tree3c8e361d078852818f76b9370b86fd8f4e818ddd /libs/easyloggingpp
parentf4ab44524385248a0258834c1f7377e6ed6fa467 (diff)
easyloggingpp: Add package
Maintainer: me@vchrist.at Compile tested: OpenWRT-23.05-rc2, arm_cortex-a7_neon-vfpv4, mips_24kc Run tested: arm_cortex-a7_neon-vfpv4 (Linksys MR8300), mips_24kc (tplink_archer-a7), OpenWrt 23.05-rc2 Description: Easylogging++ is single header efficient logging library for C++ applications. It is extremely powerful, highly extendable and configurable to user's requirements. Signed-off-by: Volker Christian <me@vchrist.at>
Diffstat (limited to 'libs/easyloggingpp')
-rw-r--r--libs/easyloggingpp/Makefile34
1 files changed, 34 insertions, 0 deletions
diff --git a/libs/easyloggingpp/Makefile b/libs/easyloggingpp/Makefile
new file mode 100644
index 000000000..a1ace21de
--- /dev/null
+++ b/libs/easyloggingpp/Makefile
@@ -0,0 +1,34 @@
+include $(TOPDIR)/rules.mk
+
+PKG_NAME:=easyloggingpp
+PKG_VERSION:=9.97.0
+PKG_RELEASE:=1
+
+PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
+PKG_SOURCE_URL:=https://codeload.github.com/abumq/easyloggingpp/tar.gz/v$(PKG_VERSION)?
+PKG_HASH:=9110638e21ef02428254af8688bf9e766483db8cc2624144aa3c59006907ce22
+
+PKG_MAINTAINER:=Volker Christian <me@vchrist.at>
+PKG_LICENSE:=MIT
+PKG_LICENSE_FILES:=LICENSE
+
+CMAKE_INSTALL:=1
+
+include $(INCLUDE_DIR)/package.mk
+include $(INCLUDE_DIR)/cmake.mk
+
+define Package/easyloggingpp
+ SECTION:=lib
+ CATEGORY:=Libraries
+ TITLE:=A single header C++ Logging Library
+ URL:=https://github.com/abumq/easyloggingpp
+ BUILDONLY:=1
+endef
+
+define Package/easyloggingpp/description
+ Easylogging++ is single header efficient logging library for C++
+ applications. It is extremely powerful, highly extendable and
+ configurable to user's requirements.
+endef
+
+$(eval $(call BuildPackage,easyloggingpp))