aboutsummaryrefslogtreecommitdiff
path: root/libs/dtndht/Makefile
diff options
context:
space:
mode:
authorJohannes Morgenroth <morgenroth@ibr.cs.tu-bs.de>2014-08-20 12:36:46 +0200
committerJohannes Morgenroth <morgenroth@ibr.cs.tu-bs.de>2014-08-20 12:43:33 +0200
commitc8b84ec8aefb26c14c92488d9b548a077f60e374 (patch)
treed864f450d5563bf65dd51561807857535294bcde /libs/dtndht/Makefile
parenta4e21e72163b443a34cb53f5e38d4aa3ee613f36 (diff)
dtndht: add new package
DTN-DHT is a library providing a fully distributed Bittorrent DHT based naming service especially for DTN Bundle Protocol EIDs (RFC 5050). It can be used for all IP (v4/v6) based networks. Signed-off-by: Johannes Morgenroth <morgenroth@ibr.cs.tu-bs.de>
Diffstat (limited to 'libs/dtndht/Makefile')
-rw-r--r--libs/dtndht/Makefile47
1 files changed, 47 insertions, 0 deletions
diff --git a/libs/dtndht/Makefile b/libs/dtndht/Makefile
new file mode 100644
index 000000000..6bc808425
--- /dev/null
+++ b/libs/dtndht/Makefile
@@ -0,0 +1,47 @@
+#
+# Copyright (C) 2014 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+include $(TOPDIR)/rules.mk
+
+PKG_NAME:=dtndht
+PKG_VERSION:=0.2.3
+PKG_RELEASE:=1
+
+PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
+PKG_SOURCE_URL:=http://www.ibr.cs.tu-bs.de/projects/ibr-dtn/releases
+PKG_MD5SUM:=37c33910ac7e760aad4db81724aeb4fb
+PKG_MAINTAINER:=Johannes Morgenroth <morgenroth@ibr.cs.tu-bs.de>
+PKG_LICENSE:=Apache-2.0
+
+PKG_INSTALL:=1
+PKG_FIXUP:=libtool
+PKG_BUILD_DEPENDS:=libopenssl
+
+include $(INCLUDE_DIR)/package.mk
+
+define Package/dtndht
+ SECTION:=libs
+ CATEGORY:=Libraries
+ DEPENDS:=+libopenssl
+ TITLE:=Library for DHT lookups for DTNs
+endef
+
+define Package/dtndht/description
+ A library with DHT functions for DTN name lookups.
+endef
+
+define Build/InstallDev
+ $(INSTALL_DIR) $(1)
+ $(CP) $(PKG_INSTALL_DIR)/* $(1)/
+endef
+
+define Package/dtndht/install
+ $(INSTALL_DIR) $(1)/usr/lib
+ $(CP) $(PKG_INSTALL_DIR)/usr/lib/lib$(PKG_NAME){.so,-$(PKG_VERSION_MAJOR).$(PKG_VERSION_MINOR).so.*} $(1)/usr/lib/
+endef
+
+$(eval $(call BuildPackage,dtndht))