aboutsummaryrefslogtreecommitdiff
path: root/libs/dtndht/Makefile
diff options
context:
space:
mode:
authorRosen Penev <rosenp@gmail.com>2018-11-27 12:36:21 -0800
committerRosen Penev <rosenp@gmail.com>2018-12-06 13:52:45 -0800
commit717423d2804db7eda624125483ecaab9d0610e68 (patch)
tree223607e8c29d91970cf19b8f5690fc76bb9c3be8 /libs/dtndht/Makefile
parent026392bcf868e5ce718ce72254ac12c01c31fdf1 (diff)
dtndht: Add -std-gnu89 to fix compilation problems.
bootstrapping.c:225:6: warning: implicit declaration of function 'blacklist_is_enabled' [-Wimplicit-function-declaration] bootstrapping.c:226:3: warning: implicit declaration of function 'blacklist_blacklist_id'; did you mean 'dht_blacklisted'? [-Wimplicit-function-declaration] Signed-off-by: Rosen Penev <rosenp@gmail.com>
Diffstat (limited to 'libs/dtndht/Makefile')
-rw-r--r--libs/dtndht/Makefile4
1 files changed, 3 insertions, 1 deletions
diff --git a/libs/dtndht/Makefile b/libs/dtndht/Makefile
index 2b79e4904..5846249ea 100644
--- a/libs/dtndht/Makefile
+++ b/libs/dtndht/Makefile
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
PKG_NAME:=dtndht
PKG_VERSION:=0.2.3
-PKG_RELEASE:=1
+PKG_RELEASE:=2
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
PKG_SOURCE_URL:=http://www.ibr.cs.tu-bs.de/projects/ibr-dtn/releases
@@ -33,6 +33,8 @@ define Package/dtndht/description
A library with DHT functions for DTN name lookups.
endef
+TARGET_CFLAGS += -std=gnu89
+
define Build/InstallDev
$(INSTALL_DIR) $(1)
$(CP) $(PKG_INSTALL_DIR)/* $(1)/