aboutsummaryrefslogtreecommitdiff
path: root/libs/dmx_usb_module
diff options
context:
space:
mode:
authorMatthias Schiffer <mschiffer@universe-factory.net>2018-02-22 00:56:05 +0100
committerMatthias Schiffer <mschiffer@universe-factory.net>2018-03-02 00:58:15 +0100
commit50cd1f13a1535dfb1222be586d117bae5bbadfd8 (patch)
treeaa91ef27b69565eae7c8b20e9c22f6b7e7b21406 /libs/dmx_usb_module
parentdee7a827300c71de06cdc6f11563e4929d33c5d5 (diff)
dmx_usb_module: fix build against kernel 4.14
The change should also work fine with older kernels, as <linux/uaccess.h> has existed for a long time, and it includes <asm/uaccess.h>. Signed-off-by: Matthias Schiffer <mschiffer@universe-factory.net>
Diffstat (limited to 'libs/dmx_usb_module')
-rw-r--r--libs/dmx_usb_module/Makefile2
-rw-r--r--libs/dmx_usb_module/patches/002-fix-build-4.14.patch11
2 files changed, 12 insertions, 1 deletions
diff --git a/libs/dmx_usb_module/Makefile b/libs/dmx_usb_module/Makefile
index 4487437d3..8f7184067 100644
--- a/libs/dmx_usb_module/Makefile
+++ b/libs/dmx_usb_module/Makefile
@@ -10,7 +10,7 @@ include $(INCLUDE_DIR)/kernel.mk
PKG_NAME:=dmx_usb_module
PKG_VERSION:=0.1.20130818
-PKG_RELEASE:=0.1
+PKG_RELEASE:=2
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
PKG_SOURCE_SUBDIR:=$(PKG_NAME)-$(PKG_VERSION)
diff --git a/libs/dmx_usb_module/patches/002-fix-build-4.14.patch b/libs/dmx_usb_module/patches/002-fix-build-4.14.patch
new file mode 100644
index 000000000..e3ae11e82
--- /dev/null
+++ b/libs/dmx_usb_module/patches/002-fix-build-4.14.patch
@@ -0,0 +1,11 @@
+--- a/dmx_usb.c
++++ b/dmx_usb.c
+@@ -20,7 +20,7 @@
+ #include <linux/module.h>
+ #include <linux/spinlock.h>
+ #include <linux/completion.h>
+-#include <asm/uaccess.h>
++#include <linux/uaccess.h>
+ #include <linux/usb.h>
+ #include <linux/version.h>
+