aboutsummaryrefslogtreecommitdiff
path: root/libs/davici
diff options
context:
space:
mode:
authorLukas Voegl <lvoegl@tdt.de>2023-10-09 10:57:29 +0200
committerLukas Voegl <lvoegl@tdt.de>2023-10-20 11:54:47 +0200
commitd5b9e9642c781e8b4f1ec70fce2fa7e783d2180b (patch)
tree26cd5a6b531f15925990694236f2c3443c45c77b /libs/davici
parenta2653fe7ca2270c9df8d4018a09caa88a55ecf92 (diff)
davici: add package
Signed-off-by: Lukas Voegl <lvoegl@tdt.de>
Diffstat (limited to 'libs/davici')
-rw-r--r--libs/davici/Makefile53
1 files changed, 53 insertions, 0 deletions
diff --git a/libs/davici/Makefile b/libs/davici/Makefile
new file mode 100644
index 000000000..54cb09c4b
--- /dev/null
+++ b/libs/davici/Makefile
@@ -0,0 +1,53 @@
+#
+# Copyright (C) 2023 TDT AG <development@tdt.de>
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See https://www.gnu.org/licenses/gpl-2.0.txt for more information.
+#
+
+include $(TOPDIR)/rules.mk
+
+PKG_NAME:=davici
+PKG_VERSION:=1.4
+PKG_RELEASE=1
+
+PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
+PKG_SOURCE_URL:=https://codeload.github.com/strongswan/davici/tar.gz/v$(PKG_VERSION)?
+PKG_HASH:=b03c5a1aad905e962271d70246d6af6c337ffd00449d990082ea02161327bde8
+
+PKG_MAINTAINER:=Lukas Voegl <lvoegl@tdt.de>
+PKG_LICENSE:=LGPL-2.1-or-later
+PKG_LICENSE_FILES:=COPYING
+
+PKG_FIXUP:=autoreconf
+PKG_BUILD_PARALLEL:=1
+PKG_INSTALL:=1
+
+include $(INCLUDE_DIR)/package.mk
+
+define Package/davici
+ SECTION:=libs
+ CATEGORY:=Libraries
+ TITLE:=Decoupled Asynchronous VICI
+ URL:=https://github.com/strongswan/davici
+endef
+
+define Package/davici/description
+ The davici library provides a client implementation of the
+ strongSwan VICI protocol for integration into external applications.
+endef
+
+define Build/InstallDev
+ $(INSTALL_DIR) $(1)/usr/include
+ $(CP) $(PKG_INSTALL_DIR)/usr/include/*.h $(1)/usr/include/
+
+ $(INSTALL_DIR) $(1)/usr/lib
+ $(CP) $(PKG_INSTALL_DIR)/usr/lib/libdavici.so* $(1)/usr/lib/
+endef
+
+define Package/davici/install
+ $(INSTALL_DIR) $(1)/usr/lib
+ $(CP) $(PKG_INSTALL_DIR)/usr/lib/libdavici.so* $(1)/usr/lib/
+endef
+
+$(eval $(call BuildPackage,davici))