aboutsummaryrefslogtreecommitdiff
path: root/libs/classpath
diff options
context:
space:
mode:
authorGuo Li <uxgood.org@gmail.com>2018-09-05 15:27:19 +0800
committerYousong Zhou <yszhou4tech@gmail.com>2018-09-06 02:07:47 +0800
commitd0e0385f1134be4ba1273b529b173fa3595debe5 (patch)
tree943de06733d2291f5bbfb2fbdd07d115e955c945 /libs/classpath
parentce013d1190f0288bce32ddceaab3477519ce0f16 (diff)
classpath: fix this statement may fall through
gnu_java_math_GMP.c:1135:13: error: this statement may fall through [-Werror=implicit-fallthrough=] res = mpz_popcount (_this); ~~~~^~~~~~~~~~~~~~~~~~~~~~ gnu_java_math_GMP.c:1136:7: note: here default: ^~~~~~~ Signed-off-by: Guo Li <uxgood.org@gmail.com>
Diffstat (limited to 'libs/classpath')
-rw-r--r--libs/classpath/Makefile2
-rw-r--r--libs/classpath/patches/020-fix-statement-may-fall-through.patch10
2 files changed, 11 insertions, 1 deletions
diff --git a/libs/classpath/Makefile b/libs/classpath/Makefile
index b795ec9d7..39a8dbcb7 100644
--- a/libs/classpath/Makefile
+++ b/libs/classpath/Makefile
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
PKG_NAME:=classpath
PKG_VERSION:=0.99
-PKG_RELEASE:=1
+PKG_RELEASE:=2
PKG_LICENSE:=GPL-2.0
PKG_MAINTAINER:=Dana H. Myers <k6jq@comcast.net>
diff --git a/libs/classpath/patches/020-fix-statement-may-fall-through.patch b/libs/classpath/patches/020-fix-statement-may-fall-through.patch
new file mode 100644
index 000000000..b31575739
--- /dev/null
+++ b/libs/classpath/patches/020-fix-statement-may-fall-through.patch
@@ -0,0 +1,10 @@
+--- a/native/jni/java-math/gnu_java_math_GMP.c
++++ b/native/jni/java-math/gnu_java_math_GMP.c
+@@ -1132,6 +1132,7 @@
+ break;
+ case 1:
+ res = mpz_popcount (_this);
++ __attribute__((fallthrough));
+ default:
+ JCL_ThrowException (env, "java/lang/Error",
+ "Unexpected sign value for a native MPI");