aboutsummaryrefslogtreecommitdiff
path: root/libs/cereal/Makefile
diff options
context:
space:
mode:
authorDavid Woodhouse <dwmw2@infradead.org>2020-06-03 17:12:56 +0100
committerDavid Woodhouse <dwmw2@infradead.org>2020-06-06 19:38:34 +0100
commit160038e7539e9755344ca3dd4fc6376f74392b3a (patch)
tree3390137de743647302850e649fdeec4dd34715a1 /libs/cereal/Makefile
parentea8f5a173bb4d518dcaabbcbc4560cdda3f23901 (diff)
cereal: new package
Signed-off-by: David Woodhouse <dwmw2@infradead.org>
Diffstat (limited to 'libs/cereal/Makefile')
-rw-r--r--libs/cereal/Makefile44
1 files changed, 44 insertions, 0 deletions
diff --git a/libs/cereal/Makefile b/libs/cereal/Makefile
new file mode 100644
index 000000000..6a2d07557
--- /dev/null
+++ b/libs/cereal/Makefile
@@ -0,0 +1,44 @@
+#
+# Copyright © 2020 David Woodhouse <dwmw2@infradead.org>
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+
+include $(TOPDIR)/rules.mk
+
+PKG_NAME:=cereal
+PKG_VERSION:=1.3.0
+PKG_RELEASE:=1
+
+PKG_SOURCE:=v$(PKG_VERSION).tar.gz
+PKG_SOURCE_URL:=https://github.com/USCiLab/cereal/archive/
+PKG_HASH:=329ea3e3130b026c03a4acc50e168e7daff4e6e661bc6a7dfec0d77b570851d5
+
+PKG_MAINTAINER:=David Woodhouse <dwmw2@infradead.org>
+PKG_LICENSE:=BSD-3-Clause
+PKG_LICENSE_FILES:=LICENSE
+
+CMAKE_INSTALL:=1
+PKG_BUILD_PARALLEL:=1
+
+CMAKE_OPTIONS += -DCMAKE_CXX_FLAGS=-latomic -DWITH_WERROR=OFF -DSKIP_PORTABILITY_TEST=ON -DSKIP_PERFORMANCE_COMPARISON=ON
+
+include $(INCLUDE_DIR)/package.mk
+include $(INCLUDE_DIR)/cmake.mk
+
+
+define Package/cereal
+ BUILDONLY:=1
+ SECTION:=devel
+ CATEGORY:=Development
+ SUBMENU:=Libraries
+ TITLE:=Cereal is a library of C++ header files for serialization
+ URL:=https://github.com/USCilab/cereal
+endef
+
+
+define Package/cereal/description
+ Cereal is a library of C++ headers for serialization
+endef
+
+$(eval $(call BuildPackage,cereal))