aboutsummaryrefslogtreecommitdiff
path: root/libs/c-ares
diff options
context:
space:
mode:
authorJo-Philipp Wich <jow@openwrt.org>2015-06-25 12:54:05 +0200
committerJo-Philipp Wich <jow@openwrt.org>2015-06-25 12:57:36 +0200
commit2e73fcd4b02cd6210c628c0c6e7a8e54cbddca41 (patch)
tree7691c1f664a553520085c53e2726f2046b8a0870 /libs/c-ares
parent07c0677b7b96cc69109b8dda9cebd01e62aa2f26 (diff)
c-ares: fix build with CONFIG_PKG_FORTIFY_SOURCE*
When fortify source is enabled, the c-ares configure script will abort with: configure: CFLAGS error: CFLAGS may only be used to specify C compiler flags, not macro definitions. Use CPPFLAGS for: -D_FORTIFY_SOURCE=1 Change the OpenWrt Makefile to move any -D flags from TARGET_CFLAGS to TARGET_CPPFLAGS in order to satisfy `configure`. Signed-off-by: Jo-Philipp Wich <jow@openwrt.org>
Diffstat (limited to 'libs/c-ares')
-rw-r--r--libs/c-ares/Makefile3
1 files changed, 3 insertions, 0 deletions
diff --git a/libs/c-ares/Makefile b/libs/c-ares/Makefile
index 815a379a3..c5b226997 100644
--- a/libs/c-ares/Makefile
+++ b/libs/c-ares/Makefile
@@ -22,6 +22,9 @@ PKG_INSTALL:=1
include $(INCLUDE_DIR)/package.mk
+TARGET_CPPFLAGS += $(filter -D%,$(TARGET_CFLAGS))
+TARGET_CFLAGS := $(filter-out -D%,$(TARGET_CFLAGS))
+
define Package/libcares
SECTION:=libs
CATEGORY:=Libraries