aboutsummaryrefslogtreecommitdiff
path: root/libs/botan
diff options
context:
space:
mode:
authorRosen Penev <rosenp@gmail.com>2019-04-14 15:32:13 -0700
committerRosen Penev <rosenp@gmail.com>2019-04-14 15:32:13 -0700
commitc6910e7e24d9943ff74b6c5bae0789091c7f9bb7 (patch)
tree66f112346addf379174d769c37efaa888bbb6dbd /libs/botan
parentf5d67fcc0fdd7c6e87d4d4cce85f4b5542af837c (diff)
botan: Disable NEON when soft float is disabled
For some reason, the build system enables NEON on platforms that is should not. Fixes compilation on several ARM targets. Signed-off-by: Rosen Penev <rosenp@gmail.com>
Diffstat (limited to 'libs/botan')
-rw-r--r--libs/botan/Makefile5
1 files changed, 4 insertions, 1 deletions
diff --git a/libs/botan/Makefile b/libs/botan/Makefile
index 2b5c8af84..1a82f4fb1 100644
--- a/libs/botan/Makefile
+++ b/libs/botan/Makefile
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
PKG_NAME:=botan
PKG_VERSION:=2.10.0
-PKG_RELEASE:=1
+PKG_RELEASE:=2
PKG_MAINTAINER:=BangLang Huang <banglang.huang@foxmail.com>
PKG_SOURCE:=Botan-$(PKG_VERSION).tgz
@@ -68,6 +68,9 @@ CONFIGURE_ARGS = \
--optimize-for-size \
$(DISABLE_IPV6)
+ifeq ($(CONFIG_SOFT_FLOAT),y)
+CONFIGURE_ARGS += --disable-neon
+endif
TARGET_LDFLAGS += \
-Wl,--gc-sections,--as-needed \