aboutsummaryrefslogtreecommitdiff
path: root/libs/boost
diff options
context:
space:
mode:
authorRosen Penev <rosenp@gmail.com>2019-10-05 16:59:41 -0700
committerRosen Penev <rosenp@gmail.com>2019-10-07 11:07:50 -0700
commitddd4109c1cc87193f2fd04eda1adb0886226fa67 (patch)
tree621068941998135505d0bd5043c2a4ebfcb7c8a6 /libs/boost
parent7a5326dd29fabf2d405603e24159323b4f792759 (diff)
boost: Remove several host libraries
The facebook people have been working on removing Boost dependencies from their projects. This is the current state. Signed-off-by: Rosen Penev <rosenp@gmail.com>
Diffstat (limited to 'libs/boost')
-rw-r--r--libs/boost/Makefile4
1 files changed, 2 insertions, 2 deletions
diff --git a/libs/boost/Makefile b/libs/boost/Makefile
index 0d52e70cd..70c630856 100644
--- a/libs/boost/Makefile
+++ b/libs/boost/Makefile
@@ -13,7 +13,7 @@ include $(TOPDIR)/rules.mk
PKG_NAME:=boost
PKG_VERSION:=1.71.0
PKG_SOURCE_VERSION:=1_71_0
-PKG_RELEASE:=3
+PKG_RELEASE:=4
PKG_SOURCE:=$(PKG_NAME)_$(PKG_SOURCE_VERSION).tar.bz2
PKG_SOURCE_URL:=@SF/$(PKG_NAME)/$(PKG_NAME)/$(PKG_VERSION) https://dl.bintray.com/boostorg/release/$(PKG_VERSION)/source/
@@ -367,7 +367,7 @@ define Host/Compile
( cd $(HOST_BUILD_DIR) ; \
./bootstrap.sh --prefix=$(STAGING_DIR_HOSTPKG) \
- --with-libraries=atomic,context,date_time,filesystem,headers,program_options,regex,system,thread ;\
+ --with-libraries=context,filesystem,program_options,regex,system ;\
./b2 --ignore-site-config install )
endef