aboutsummaryrefslogtreecommitdiff
path: root/libs/boost
diff options
context:
space:
mode:
authorTed Hess <thess@kitschensync.net>2016-10-04 16:30:29 -0400
committerTed Hess <thess@kitschensync.net>2016-10-04 18:51:26 -0400
commit75a74f41e35442da4e316d6e2c32aac3cf541d19 (patch)
tree9a74ca49b459e832962ab857764b4e45972b3d94 /libs/boost
parent577111109d49d83b676c63971fab85e540dfb10e (diff)
boost: Fix immediate build problems until 1.62 update available
boost: Correct Sourceforge URI for boost releases Signed-off-by: Ted Hess <thess@kitschensync.net>
Diffstat (limited to 'libs/boost')
-rw-r--r--libs/boost/Makefile30
1 files changed, 12 insertions, 18 deletions
diff --git a/libs/boost/Makefile b/libs/boost/Makefile
index ceb3e3506..6dce9ee5a 100644
--- a/libs/boost/Makefile
+++ b/libs/boost/Makefile
@@ -1,5 +1,5 @@
#
-# Copyright (C) 2015 OpenWrt.org
+# Copyright (C) 2015-2016 OpenWrt.org
#
# This is free software, licensed under the GNU General Public License v2.
# See /LICENSE for more information.
@@ -16,13 +16,14 @@ include $(INCLUDE_DIR)/nls.mk
include $(INCLUDE_DIR)/target.mk
PKG_NAME:=boost
-PKG_VERSION:=1_61_0
-PKG_RELEASE:=1
-
-PKG_SOURCE:=$(PKG_NAME)_$(PKG_VERSION).tar.gz
-PKG_SOURCE_URL:=@SF/boost
-PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)_$(PKG_VERSION)
-HOST_BUILD_DIR:=$(BUILD_DIR_HOST)/$(PKG_NAME)_$(PKG_VERSION)
+PKG_VERSION:=1.61.0
+PKG_SOURCE_VERSION=1_61_0
+PKG_RELEASE:=2
+
+PKG_SOURCE:=$(PKG_NAME)_$(PKG_SOURCE_VERSION).tar.gz
+PKG_SOURCE_URL:=@SF/boost/$(PKG_NAME)/$(PKG_VERSION)
+PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)_$(PKG_SOURCE_VERSION)
+HOST_BUILD_DIR:=$(BUILD_DIR_HOST)/$(PKG_NAME)_$(PKG_SOURCE_VERSION)
PKG_MD5SUM:=874805ba2e2ee415b1877ef3297bf8ad
PKG_LICENSE:=Boost Software License <http://www.boost.org/users/license.html>
PKG_MAINTAINER:=Carlos M. Ferreira <carlosmf.pt@gmail.com>
@@ -43,10 +44,6 @@ define Package/boost/Default
DEPENDS:=+libstdcpp +libpthread +librt
endef
-define Package/boost/description/Default
- true
-endef
-
define Package/boost/description
This package provides the Boost v1.61 libraries.
Boost is a set of free, peer-reviewed, portable C++ source libraries.
@@ -91,8 +88,6 @@ $(call Package/boost/Default)
endef
define Package/boost-libs/description
-$(call Package/boost/description/Default)
- .
This meta package contains only dependencies to the other libraries from
the boost libraries collection.
endef
@@ -225,7 +220,7 @@ define Package/boost/config
select PACKAGE_boost-test
config boost-coroutine2
- depends on @GCC_VERSION_5
+ depends on @(GCC_VERSION_5 || GCC_VERSION_6)
bool "Boost couroutine2 support."
select PACKAGE_boost-coroutine
default n
@@ -238,6 +233,7 @@ define Package/boost/config
$(foreach lib,$(BOOST_LIBS), \
config PACKAGE_boost-$(lib)
prompt "Boost $(lib) library."
+ $(if $(findstring locale,$(lib)),depends on @BUILD_NLS,)
)
endmenu
@@ -273,8 +269,6 @@ define DefineBoostLibrary
endef
define Package/boost-$(1)/description
- $(call Package/boost/description/Default)
- .
This package contains the Boost $(1) library.
endef
endef
@@ -290,7 +284,7 @@ $(eval $(call DefineBoostLibrary,date_time,,))
$(eval $(call DefineBoostLibrary,filesystem,system,))
$(eval $(call DefineBoostLibrary,graph,regex,))
$(eval $(call DefineBoostLibrary,iostreams,,+PACKAGE_boost-iostreams:zlib))
-$(eval $(call DefineBoostLibrary,locale,system,$(ICONV_DEPENDS) @BUILD_NLS))
+$(eval $(call DefineBoostLibrary,locale,system,$(ICONV_DEPENDS)))
$(eval $(call DefineBoostLibrary,log,system chrono date_time thread filesystem regex,))
$(eval $(call DefineBoostLibrary,math,,))
#$(eval $(call DefineBoostLibrary,mpi,,)) # OpenMPI does no exist in OpenWRT at this time.