aboutsummaryrefslogtreecommitdiff
path: root/libs/boost/Makefile
diff options
context:
space:
mode:
authorAndre Heider <a.heider@gmail.com>2023-03-23 09:27:01 +0100
committerAndre Heider <a.heider@gmail.com>2023-04-08 08:38:54 +0200
commite7d9c865036d7bc2ac30604e8573f25ae601aed1 (patch)
tree5efb8a25df387e8e79356447c648ecc3306176b3 /libs/boost/Makefile
parent35f4ef76e0c88b690ec55f26aed072c4c5989eff (diff)
treewide: refactor to use PKG_BUILD_FLAGS:=lto
See commit 07730ff3 "treewide: add support for "lto" in PKG_BUILD_FLAGS" on the main repository. Note: Some packages only added `-flto` to CFLAGS and not LDFLAGS. This fixes it and properly enables LTO. Signed-off-by: Andre Heider <a.heider@gmail.com>
Diffstat (limited to 'libs/boost/Makefile')
-rw-r--r--libs/boost/Makefile4
1 files changed, 2 insertions, 2 deletions
diff --git a/libs/boost/Makefile b/libs/boost/Makefile
index cb92e27a4..295e4b243 100644
--- a/libs/boost/Makefile
+++ b/libs/boost/Makefile
@@ -29,7 +29,7 @@ HOST_BUILD_DIR:=$(BUILD_DIR_HOST)/$(PKG_NAME)_$(PKG_SOURCE_VERSION)
HOST_BUILD_PARALLEL:=1
PKG_BUILD_PARALLEL:=1
-PKG_BUILD_FLAGS:=no-mips16 gc-sections
+PKG_BUILD_FLAGS:=no-mips16 gc-sections lto
include $(INCLUDE_DIR)/package.mk
@@ -382,7 +382,7 @@ CONFIGURE_PREFIX:=$(PKG_INSTALL_DIR)
TARGET_LDFLAGS += -pthread -lrt -lstdc++ -Wl,--as-needed,--print-gc-sections
TARGET_CFLAGS += \
- $(if $(CONFIG_SOFT_FLOAT),-DBOOST_NO_FENV_H) -fPIC -flto
+ $(if $(CONFIG_SOFT_FLOAT),-DBOOST_NO_FENV_H) -fPIC
ifeq ($(word 1,$(subst ., ,$(call qstrip,$(CONFIG_GCC_VERSION)))),5)
EXTRA_CXXFLAGS += -std=gnu++14