aboutsummaryrefslogtreecommitdiff
path: root/libs/boost/Makefile
diff options
context:
space:
mode:
authorAmol Bhave <ambhave@fb.com>2019-05-07 00:31:01 -0700
committerAmol Bhave <ambhave@fb.com>2019-05-07 00:56:55 -0700
commit48e844101b88018ee2828431c39e514649ad7ae1 (patch)
tree6d547a27ee23aaf1e57c017bbc2b967f1a94944b /libs/boost/Makefile
parent20667b5ea21ce0560627cc979232f0a7e83663fb (diff)
boost: Fix boost apply_visitor for lvalue variants
Boost 1.70.0 broke the apply_visitor functions for lvalue reference variants. This imports the patch that fixes this issue from upstream. Tested this by compiling a library (https://github.com/facebookincubator/fizz) that works with 1.69 but breaks with 1.70. And then, importing this patch and trying the compilation again. Compile tested: nbg6817 Maintainer: @ClaymorePT Signed-off-by: Amol Bhave <ambhave@fb.com>
Diffstat (limited to 'libs/boost/Makefile')
-rw-r--r--libs/boost/Makefile2
1 files changed, 1 insertions, 1 deletions
diff --git a/libs/boost/Makefile b/libs/boost/Makefile
index 6a87228b2..c032a1363 100644
--- a/libs/boost/Makefile
+++ b/libs/boost/Makefile
@@ -13,7 +13,7 @@ include $(TOPDIR)/rules.mk
PKG_NAME:=boost
PKG_VERSION:=1.70.0
PKG_SOURCE_VERSION:=1_70_0
-PKG_RELEASE:=3
+PKG_RELEASE:=4
PKG_SOURCE:=$(PKG_NAME)_$(PKG_SOURCE_VERSION).tar.bz2
PKG_SOURCE_URL:=@SF/$(PKG_NAME)/$(PKG_NAME)/$(PKG_VERSION) https://dl.bintray.com/boostorg/release/$(PKG_VERSION)/source/