aboutsummaryrefslogtreecommitdiff
path: root/libs/boost/Makefile
diff options
context:
space:
mode:
authorRosen Penev <rosenp@gmail.com>2019-09-23 11:11:06 -0700
committerRosen Penev <rosenp@gmail.com>2019-09-23 11:29:52 -0700
commit1f77459acef49003529ce5bf26ed4c476648e097 (patch)
treeb733980773d9a5aec442975f8f2171ed9fe5e83f /libs/boost/Makefile
parenta2bbedb880ff9d37549c1e0e334177ce0dc88937 (diff)
boost: Update host libraries
It seems newer versions of fbthrift require more libraries. Also added AR7, RB532, and Lantiq ASE to fiber exclusion. Signed-off-by: Rosen Penev <rosenp@gmail.com>
Diffstat (limited to 'libs/boost/Makefile')
-rw-r--r--libs/boost/Makefile6
1 files changed, 3 insertions, 3 deletions
diff --git a/libs/boost/Makefile b/libs/boost/Makefile
index dc7fab029..1c8e4fe5c 100644
--- a/libs/boost/Makefile
+++ b/libs/boost/Makefile
@@ -13,7 +13,7 @@ include $(TOPDIR)/rules.mk
PKG_NAME:=boost
PKG_VERSION:=1.71.0
PKG_SOURCE_VERSION:=1_71_0
-PKG_RELEASE:=1
+PKG_RELEASE:=2
PKG_SOURCE:=$(PKG_NAME)_$(PKG_SOURCE_VERSION).tar.bz2
PKG_SOURCE_URL:=@SF/$(PKG_NAME)/$(PKG_NAME)/$(PKG_VERSION) https://dl.bintray.com/boostorg/release/$(PKG_VERSION)/source/
@@ -130,7 +130,7 @@ define Package/boost/config
config boost-fiber-exclude
bool
- default y if (TARGET_brcm47xx_generic || TARGET_brcm47xx_legacy || mips32 || mips64 || boost-coroutine-exclude)
+ default y if (TARGET_ar7 || TARGET_brcm47xx_generic || TARGET_brcm47xx_legacy || TARGET_lantiq_ase || TARGET_rb532 || mips32 || mips64 || boost-coroutine-exclude)
default n
menu "Select Boost Options"
@@ -367,7 +367,7 @@ define Host/Compile
( cd $(HOST_BUILD_DIR) ; \
./bootstrap.sh --prefix=$(STAGING_DIR_HOSTPKG) \
- --with-libraries=atomic,chrono,date_time,filesystem,headers,thread,system ;\
+ --with-libraries=atomic,context,date_time,filesystem,headers,program_options,regex,system,thread ;\
./b2 --ignore-site-config install )
endef